1

I have been using the Brother MFC-J6935DW printer, for almost a year, with Ubuntu 16.04 over wifi. Worked like a charm. Yesterday, I upgraded to Ubuntu 18.04. Most things went off pretty well. The only challenge I have not been able to resolve is that the printer starts spewing out garbage after the first couple of lines. The things I have tried are: a. Reinstall printer b. Download the driver from the brother site and reinstall that. c. sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6 (as suggested on another thread here). d. Reinstalled Ms fonts e. Upgraded to the latest firmware.

No luck as yet. Any suggestions, please? The only workaround I have at the moment is to print the pdf document as an image (I really need to get this resolved before my wife needs to use the printer!).

Attached is an image of what I get when I try to print a standard document. PrintOutSample

0

No solution but sympathy, I've got a very similar problem. Upgraded from 16.04 LTS due to sound issues. Sound issues disappeared but now my Brother MFC-J5910DW won't scale the pages. Test page 100% fine, print preview looks great but every time I print from the web or documents I either get miniature print or outsize print. Last time I tried to set the paper size the selection was greyed out and set to 'Letter' (printing on A4). I had some printer set up issues a while back but happy printing for over a year now. Tried deleting and reloading cups - no joy. I have a feeling your solution will be my solution so any advice gratefully received.

  • The only workaround for me, at the moment, is to print the pdf documents as an image. The one other thing I have not tried is to download the document and then print it. I do acknowledge I am just troubleshoot (and guessing) here - no concrete reason for the downloaded document to print different from the one direct off the web. – sunil Oct 1 '18 at 4:16
0

I also had issues after update from 16.04 to 18.04. Spent a few days diagnosing the issue. I found the following article very helpfull.

DissectingandDebuggingtheCUPSPrintingSystem and checking the error_log after crancking up the debug level to 2. check the logfile for errors and entries that might indicate errors and try to intercept the document you print at different times during the conversion chain.

  • Thanks G3cko___. I can't immediately confirm or deny as my solution was to rollback to 16.04 (As I hinted, family harmony was more important than cutting-edge technology). Will only know once I have time to retry working with 18.04. – sunil Oct 17 '18 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.