0

First - I will try to provide as much info as possible, but I received my computer as a gift, so I am not the most computer savvy...

I am running Ubuntu on a partitioned Chromebook, for the last...2+ years? no major issues. Now, I was watching a movie from the external hard drive and mid-transmission, it stopped, I received an error message that it could no longer source the file and the hard drive was no longer visible, although the light on the hard drive was still on. I KNOW THIS WAS BAD, but I unplugged it and tried to plug it in again - to no avail.

Fast forward to next day, still no luck, I try running some commands to force it to mount, but it doesn't even "see" it. So I restart my computer with the hard drive plugged in. When it restarts, several things happen:

-the hard drive light is no longer on, but I hear whirring/clicking from inside -the font of my computer is different - like the numbers of the clock, etc -the power indicator is no longer visible next to the other icons

I tried to address the power indicator issue, trying various things to install, purge, reinstall, etc etc. It goes through some processes but there is always some kind of error indicated. Most recently, this:

E: Failed to fetch http://fr.archive.ubuntu.com/ubuntu/pool/main/ii/indicator-power/indicator-power_12.10.6+15.04.20150402-0ubuntu1_amd64.deb Size mismatch

It suggests running

apt-get update or to try --fix missing.

When I run the update command I end up with

E: GPG error: http://dl.google.com stable InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

And I don't know what any of that means...

So I can't figure out what the issue is with the power indicator, I'm getting all kinds of messages...the font has changed which also worries me that there's something going on that I'm not aware of, and I have a lot of very important material on my external hard drive that I really need access to! Additionally - I am working abroad at the moment with limited access to assistance, which is why I need to try and fix this on my own.

Any and all suggestions are appreciated. Thank you!

EDIT: I am wondering if I should try to mount my hard drive on another computer - I do not know anyone who runs any Linux system here, so I'm not sure if that matters. Also, if there is somehow something on my hard drive that infected my computer, I wouldn't want to pass that along (not even sure if that's possible here...)

EDIT 2: I am trying to fix the font issue, tried to install the unity tweak tool, but I get a similar error as above of a "Size Mismatch" - I've never seen this before - what does it mean and how can I address it?

EDIT 3: I fully shutdown computer and started (without hard drive plugged in) and the font has returned to normal and power-indicator is back - does this mean there is an issue affecting my computer from the hard drive itself?

  • This appears to be a hardware issue - I suspect it to be a broken external power supply of your harddisk in the best case. As it may only be cables, I'd check that first (a loose connection will give you intermittent power to that drive). – Takkat Sep 19 '18 at 7:41
  • What version of Ubuntu are you running? The package indicator-power_12.10.6+15.04.20150402-0ubuntu1_amd64.deb contains the date 2015-04-02 implying you are running 15.05 (which is EOL)? The following are supported packages packages.ubuntu.com/search?keywords=indicator-power (I acknowledge 18.04 & 18.10 still use the 17.10 dated file, but your date is between 14.04 LTS & 16.04 LTS) This would explain your "failed to fetch" – guiverc Sep 19 '18 at 8:46
  • Replace the USB cable you use to attach you external drive. A short circuit in this cable may affect both, your computer and the harddrive. – Takkat Sep 19 '18 at 9:36
0

The drive in question or some other hardware component broke. Hopefully it’s just the USB cable or power adapter (if the drive requires one at all) which you can exchange on your own. You can also try to connect the drive to a different computer on the odd chance that the USB port on your computer broke.

Otherwise you have a new paperweight for your desk instead of a storage device. A data recovery specialist will likely be able to recover all or most of the data on the drive using special equipment but they tend to charge at least around 100 USD if they’re worth their salt.

The power-indicator package will not help you with this issue in any conceivable way.


The software installation issues in your question is entirely unrelated and you should open a new question if you want us to help you address it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.