0

After installing Ubuntu 18.04 64-bit on a separate HDD I am able to access grub by pressing F10 and manually choosing a boot option (Intel DQ67SW motherboard) and launch either Windows 10 or Ubuntu. However if I don't press F10 and try to let the PC boot normally instead of getting the grub menu, the PC goes into an infinite loop of displaying the motherboard splash screen -> displaying a black screen with some text for a split second (way to fast for me to read the text) -> back to the splash screen.

Does anyone know how to fix this?

I have tried boot-repair as well as running bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi in the Windows command prompt, and neither have fixed the issue.

Output from sudo parted -l :

Model: ATA WDC WD10EZEX-08W (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  577MB   576MB   ntfs               hidden, diag
 2      577MB   1000GB  1000GB  ntfs               msftdata
 3      1000GB  1000GB  105MB   fat32              boot, esp


Model: ATA WDC WD10EZEX-08W (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  538MB   537MB   fat32        EFI System Partition  boot, esp
 2      538MB   1000GB  1000GB  ext4

My boot order is currently

  • P1: WDC WD10EZEX-08WN4A07 (HDD Ubuntu is installed on)
  • P0: WDC WD10EZEX-08WN4A07 (HDD Windows is installed on)

I have tried having P0 first, but I get the same result.

My boot menu looks like this:

IBA GE Slot 00C8 v1395
P0: WDC WD10EZEX-08WN4A07
P1: WDC WD10EZEX-08WN4A07
UEFI: WDC WD10EZEX
UEFI: WDC WD10EZEX-08WN4A07
ubuntu
ubuntu
Windows Boot Manager

Edit 2: I got fed up and just did a backup and clean reinstall of both Ubuntu and Windows. It still didn't work. Then I plugged out the Windows HDD. Linux wouldn't boot. Plugged out Linux. Windows would boot. Plugged in only Linux again it booted. Plugged in both and I got grub... so.. plugging the HDDs in and out solved the issue for some reason.

  • 1
    Boot into Ubuntu (F10). Run command sudo parted -l, and show output in question. Also in BIOS what is shown as 1st boot option? – Paul Benson Sep 19 '18 at 2:06
  • I've edited my post to include the information you requested – Pierre de Villiers Sep 19 '18 at 7:30
  • Your partitioning looks OK. I think this could be a BIOS config issue. Before we look at that I'm a little confused by your boot priority. Can you go back into Ubuntu and run efibootmgr and put that up as well? – Paul Benson Sep 19 '18 at 13:35
  • Have you updated UEFI from vendor? Many early UEFI have issues that have been corrected with updates. Grub normally installs /EFI/ubuntu boot folder to first ESP, normally sda and normally the Windows drive ESP. Only if when you installed, you disconnected other drive, do you get total separation. Post link to Summary Report as that gives lots of details on configuration: help.ubuntu.com/community/Boot-Repair – oldfred Sep 29 '18 at 15:07
1

I've just had an identical result with this motherboard dual booting. I videoed the error and slowed it down: The error is system bootorder not found

I had to boot into a Linux live CD and mess with efibootmgr (a lot!) to get my Windows boot going again. This is a pretty old board now and I'm pretty convinced now that its UEFI is just old and buggy.

I ended up getting dual-boot set up by setting the machine to non-UEFI mode and installing a traditional mode Grub bootloader on my new Linux HDD. I then switched back to UEFI.

To boot Windows I leave the machine alone and it auto boots normally. To boot Linux, I hit F10 at boot and manually select the hard disk Linux is installed on. Hacky, but it works for me.

I spent many hours trying to get it to boot Linux in UEFI mode alongside Windows and it just does not work on this motherboard.

| improve this answer | |
  • Might not be what OP wants to hear, but "it just doesn't work on this hardware" is a valid answer – Zanna Sep 30 '18 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.