0

After running Powertop to do some tests with power usage, I realised that I have two USB devices listed that are not actually in use and that I would like to remove completely from my system.

USB device: usb-device-8087-0a2b
USB device: XiaoMi USB 2.0 Webcam (SunplusIT Inc)

When I installed Ubuntu I checked the option to automatically install drivers, so I'm going to suppose that's where these two came from.

Is there a way I can

  • Understand what the first one is
  • Figure out the drivers connected to both
  • Remove those drivers so that they wouldn't get activated anymore

I don't have any other information about what they could be and nothing else is connected via USB to the laptop.

I'm on Ubuntu 18.04.01 LTS

Edit: I checked in System Monitor and I can't find anything that could be related to them.

Edit 2: Running for device in $(ls /sys/bus/usb/devices/*/product); do echo $device;cat $device;done

Resulted in

/sys/bus/usb/devices/1-5/product
XiaoMi USB 2.0 Webcam

and lsusb

Resulted in:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 8087:0a2b Intel Corp. 
Bus 001 Device 003: ID 04f3:0c1a Elan Microelectronics Corp. 
Bus 001 Device 002: ID 05c8:03a2 Cheng Uei Precision Industry Co., Ltd (Foxlink) 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Which should be the first

Edit 3: echo '1-5' | sudo tee /sys/bus/usb/drivers/usb/unbind

Resulted in

1-5
tee: /sys/bus/usb/drivers/usb/unbind: No such device
  • 1
    output of for device in $(ls /sys/bus/usb/devices/*/product); do echo $device;cat $device;done ? – j-money Sep 18 '18 at 21:11
  • 2
    Please edit your question to add the result of the terminal command: lsusb I suspect the first isting is bluetooth. – chili555 Sep 18 '18 at 21:15
  • Added output of both commands with results, I'm still unsure what the bluetooth one actually is but how would I go about removing the Webcam in the meantime – creativiii Sep 18 '18 at 21:20
  • Nevermind I copied the wrong one, the bluetooth one is something related to intel so it's probably best to keep it. – creativiii Sep 18 '18 at 21:25
  • maybe try echo '1-5' | sudo tee /sys/bus/usb/drivers/usb/unbind? to disable the webcam – j-money Sep 18 '18 at 21:26
3

The first item is this:

USB device: usb-device-8087-0a2b  

A search for the usb.id 8087:0a2b suggests that is the bluetooth segment of the wireless/bluetooth card. Generally, in Settings, there is a slider to turn bluetooth off and on.

The second item is this:

05c8:03a2 Cheng Uei Precision Industry Co., Ltd (Foxlink) 

Searching for that wording finds this page: https://certification.ubuntu.com/catalog/make/Cheng%20Uei%20Precision%20Industry%20Co.%2C%20Ltd%20%28Foxlink%29/

This seems to confirm that the device is the webcam. Next, we find this: https://www.linuxquestions.org/questions/linux-software-2/webcam-not-recognized-4175495176/ That page suggests that the driver is uvcvideo. Confirm that it is loaded:

lsmod | grep video

If it is, and you wish to disable the device altogether, blacklist the driver:

sudo -i
echo "blacklist uvcvideo"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r uvcvideo
exit

The driver has a long list of dependencies, one or more of which may load despite the blacklist. We may need to blacklist a few more after a trial and error.

EDIT: Reboot and see if there are any of these still loaded: uvcvideo,videodev,videobuf2-core,videobuf2-v4l2,videobuf2-vmalloc,media

If so, blacklist them one at a time and reboot and check again until none is left.

| improve this answer | |
  • uvcvideo was loaded. I blacklisted it but the webcam is still there. – creativiii Sep 18 '18 at 21:59
  • See my edit above in a few moments. – chili555 Sep 18 '18 at 22:00
  • None were loaded, although I found video 45056 1 i915 not sure if it's related – creativiii Sep 18 '18 at 22:05
  • i915 is your video card driver; I doubt that it is related. Do not blacklist video. I think you are all set! – chili555 Sep 18 '18 at 22:09
  • If my answer has been helpful, please accept it: askubuntu.com/tour – chili555 Sep 18 '18 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.