0

Surface Pro-2, i5, 256SSD, Ubuntu-16.04 and win8.1 dual boot. Default is 16.04.

Using the 18.04 install disk and GParted I shrunk the existing 16.04 partition and removed the swap file. Rebooted to 16.04 and all was good then went back to the 18.04 install and it too worked well afterwards, but now booting to 16.04 is now painfully slow.

I removed the swap entry in the /etc/fstab but boot is still painfully slow at over a minute-thirty-seconds. It used to be about twelve-seconds.

I then tried "systemd-analyze critical-chain" from a Comment here Slow boot after partition resize (editing fstab not working)

Everything on the resulting display starting with "graphical.target @1min 37.118s" and reduces down the list to "sysinit.target @1min 31.189s," so only covering around six-seconds. That is fast enough.

Then comes "brltty.target @4.839s" next on that list, so what is happening in between "sysinit.target" and "brltty.target?"

What do I try next?

Thanks

1

Swap partition it is not only present in to fstab, also in to /etc/initramfs-tools/conf.d/resume; after you remove the UUID of the swap partition update the initramfs and boot should be again fast.

P.S. check also in /etc/default/grub if there is also declared the RESUME partition.

Off course you have to remove it if there have no swap partition anymore, if you have one just update it with the right UUID

  • Thanks for the reply, but that didn't fix it. There was an unknown UUID in the file, probably the old swap I deleted. I found another page here that suggested adding RESUME=none in the initramfs file then sudo update-initramfs -u but that has not helped. It s still taking the same 1min-35sec for the rolling dots to quit and get to the login screen. And, there is no swap. – LinuxFerLife Sep 18 '18 at 18:52
  • You could take out the "quite" at boot time and take a look where the boot process spend more time, from there we can have some think where to start. – AtomiX84 Sep 18 '18 at 20:13
  • Thanks again. OK, It hangs after Started Tell Plymouth to write out runtime data. Then it flashes a wide message about (2 of 2)A Start job is running for dev-disk-by\x2duuid-c96... It alternates with something about dev mapper crypt swap but all going by too fast. It counts down but the count down restarts each time it flashes. Eventually it just times out with that message, then boots OK. – LinuxFerLife Sep 18 '18 at 21:32
  • OK, just managed to capture the other message. (2 of 2) A stat job is running for dev-mapper-cryptswap1.device (1min 15sec / no limit) – LinuxFerLife Sep 18 '18 at 21:39
  • 1
    I find out this github.com/pop-os/pop/issues/316 that says have another place swap partition is recorded, /etc/crypttab, after comment out also there the swap partition update the initramfs and try restart, I hope this gonna to fix your issue – AtomiX84 Sep 18 '18 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.