1

I have setup ubuntu server 16.04. Have put two network cards, both to connect to a single network of 172.18.6.0/24 They have different IPs in that if one goes down, the other can keep up activity.

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 172.18.6.101
        netmask 255.255.255.0
        gateway 172.18.6.1
# eth1 config
auto eth1
iface eth1 inet static
        address 172.18.6.102
        netmask 255.255.255.0
        gateway 172.18.6.1

but aftersetup, I realise one NIC is connecting and the other is not connecting. both show up when i do

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:15:5d:00:5a:12 brd ff:ff:ff:ff:ff:ff
    inet 172.18.6.101/24 brd 172.18.6.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fe00:5a12/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:15:5d:00:5a:13 brd ff:ff:ff:ff:ff:ff
    inet 172.18.6.102/24 brd 172.18.6.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fe00:5a13/64 scope link
       valid_lft forever preferred_lft forever

How can i have both NICs active?

  • Hello and welcome to Ask Ubuntu! What do you mean one is not connecting? Do you mean the link won't go up? Care to share a bit more info about your setup? Also, can you edit your question and post the output of ip link show? – Mr Shunz Sep 18 '18 at 15:18
  • With "packet routing" - see man ip-route – waltinator Sep 18 '18 at 15:23
  • I dont know what changed, but later on. Both NIC started working. I can access the server through any of the IPs. Thanks. – Elly Rwanyaraale Sep 25 '18 at 6:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.