1

I've printed a PDF file one-sided as follows:

lpr -P Canon_MG5600_series -o sides=one-sided document.pdf 

The result is as expected (see left side of the image bellow).

However, when trying to print the same file in duplex:

lpr -P Canon_MG5600_series -o sides=two-sided-long-edge document.pdf 

The page gets cropped at the top (see right side of the image bellow).

Printed documents

Any ideas how to get it working properly?

EDIT1: Tried printing via system dialog with same results

2
  • It looks like you print a "Portrait" as "Landscape", try -o orientation-requested=3 , it is "portrait orientation (no rotation)". Ref.: cups.org/doc/options.html#OPTIONS
    – MatsK
    Sep 18, 2018 at 14:33
  • @MatsK Thanks for the idea, but printing with -o orientation-requested=3 didn't change anything. I've tried printing even with system dialog, but the result is the same.
    – Adam
    Sep 18, 2018 at 14:46

1 Answer 1

0

Apparently it was a driver-related issue. After installing official printer drivers from the manufacturer it started working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .