I got a Lenovo T420s with a dedicated NVS 4200M Graphics Card running Ubuntu 18.04 and want to connect to an external monitor with WQHD resolution. However, when joining displays, the external monitor's max resolution only goes up to 1920x1080 in the Displays settings:

Display settings

I tried connecting with both HDMI and DP. Weirdly, when I use DP, the monitor stays dark altogether (and does only "occasionally" show up in Displays settings), but I can drag windows over to it.

What more can I do to debug this?

  • Which nVidia driver version are you using? According to the nVidia Technical specifications, the HDMI only goes to FHD, so you should use the DP to go up to WQHD. Have you tried a cold boot after hooking up the DP? – Fabby Sep 26 '18 at 18:04
  • Have you tried only using the WQHD monitor (like closing the laptop screen while it's plugged in to force it to or something)? I'm wondering if that card can't handle pushing both your laptop screen and the WQHD combined. – Vardogor Sep 26 '18 at 21:42
  • When you type xrandr in the command line it should return all available resolutions. Do you see what you expect there? – WinEunuuchs2Unix Sep 30 '18 at 19:30
  • To the first two posters: Both of that doesn't help. I have nvidia-driver-390 installed and (supposedly) running. @WinEunuuchs2Unix the output of xrandr is not promising, it only shows LVDS-1-1 connected primary 1600x900+0+0 and some resolutions, and then VGA-1-1 disconnected. But it doesn't even show the DP or HDMI connector (note, however, that this is after I installed a new driver.. before, xrandr would at least show some more connectors). – wnstnsmth Oct 17 '18 at 17:40

I solved this problem by following this answer to a similar question on ubuntuforums.org:

Disabling NVIDIA KMS (enabled by default in 390.77) resolves the issue:

Edit /lib/modprobe.d/nvidia-kms.conf file and set modeset to 0:
options nvidia-drm modeset=0

Save, update initramfs and reboot:

sudo update-initramfs -u


Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.