0

I'm trying to install Virtualbox on my Ubuntu 18.04 but I encountered some problems because of Secure Boot. So I'm following this tutorial which seems a good solution.

But here is my problem : When I reboot and choose 'Enroll MOK' on the 'blue window', I enter my password, but it always fail... I tried many times, and everytime I remove .priv and .der files to re-generate them with openssl command, but agains and again :

"The password doesn't match"

I'm pretty sure that I enter the same password when I generate files with mokutil command.

Am I missing something ?

1

After several attempts, I finally found a solution... The password cannot be longer than x characters, and I think is 5, according to this post.

I find it strange, but I hope it can help someone !

  • Well the prompt for password during the NVidia driver install complains if I try to use a short password: "The Secure Boot key you've entered is not valid. The password used must be between 8 and 16 characters." – Gunnar Forsgren - Mobimation Apr 25 '19 at 10:00
  • 1
    It asks you for the secure boot password, this post is about a MOK password. I think you've choose your secure boot password when you installed your OS. – Rémi Apr 25 '19 at 10:14
0

It worked for me in this way:

Use letters (I had nine letters) instead of numbers (like it is indicated in many examples) for the temporal password, when it is created using:

sudo mokutil --disable-validation

Then:

  • Reboot.

  • Press any key when the MOK management blue screen is displayed.

  • Select "Change Secure Boot state".

  • Enter, one at at time, the letter of your pasword at the asked position and hit enter.

  • After several letters (not all were tested), answer yes to "disable Secure Boot".

  • Start the PC.

  • Open a terminal in your Linux environment.

  • Load the vboxdrv modules with

    lsmod | grep vboxdrv
    
  • The following message is displayed when the modules are correctly loaded

    vboxdrv               454656  3 vboxnetadp,vboxnetflt,vboxpci
    

And that's it!

0

I had the same problem and it enventually worked by typing the password as if I had a qwerty keyboard in the MOK manager, though it is an azerty one... (note that I used a short password as suggested, I don't know if this counted as well...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.