0

On Xubuntu I have shortcut-key Super for command "xfce4-appfinder". So now I have difficulties when I use combinations with key Super.

For example when I press Super+F1, two commands "xfce4-appfinder" and "xfce4-find-cursor" run at the same time.

It's not normal behavior. I guess it's only Xubuntu/xfce problem. Please help to fix it.

  • Wasn't Alt+F2 the original shortcut for xfce4-appfinder? Why did to change it to Super? You've seen the consequences. – DK Bose Sep 17 '18 at 14:54
  • Because it's faster to use one key than two. It doesn't matter what command is, I just want to use "Super" key for something, and I can't. – tehkonst Sep 17 '18 at 15:11
  • Yes, that's quite obvious and equally obvious is that you'll have two effects each time you use Super+anything. Change plain super to say, super+spacebar. If that's possible, I don't see how much longer that's going to take. And it's not like you're going to be using xfce4-appfinder that often to think in terms of saving significant amounts of time. – DK Bose Sep 17 '18 at 15:15
2

ksuperkey solved my problem - https://github.com/hanschen/ksuperkey

Just follow instruction for compiling ksuperkey - https://store.kde.org/p/1081256/

Compiling from source

If there is no package for ksuperkey for your distribution, you can compile the program from source following these instructions:

  1. Install dependencies. On Ubuntu:

sudo apt-get install gcc make libx11-dev libxtst-dev pkg-config

On some system you'll also have to install the build-essential package.

  1. Download ksuperkey-0.4 (Source) from this page and extract the tar.gz file (using e.g. Ark).

  2. Go to the newly extracted directory called ksuperkey, open a terminal (press F4 in Dolphin), and run:

make

3b. Optionally, if you want to install ksuperkey to the standard PATH for all users:

sudo make install

  1. Launch ksuperkey:

./ksuperkey

or by clicking on its icon. ksuperkey will run in the background. (If you did step 3b, you can just type "ksuperkey" from anywhere to launch it.)

  1. Try to press the left Super key. If the application launcher does not show up, make sure that its shortcut is set to Alt+F1: right click on the application launcher icon -> Application Launcher Settings -> Keyboard Shortcut.

Then launch ksuperkey -e 'Super_L=Alt_L|F3' or add the command to autostart.

Update. Maybe it's better to use xcape instead. Because it's original, from where ksuperkey was forked.

Installation and command is the same - xcape -e 'Super_L=Alt_L|F3'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.