0

Yesterday 16/9, I did an update on Libre Office as per "update" message from Ubuntu 18.04 Developer Edition . This morning I want to start Libre office and it does not load any existing/new documents. You get the main LO screen and when you select your document, it blinks ....... and its closed.

LibreOffice 6.0.6.2 Build ID: 1:6.0.6-0ubuntu0.18.04.1

I have tried the following solution but it did not work: "Deleting" the .config/libreoffice directory

Pls advise

As per DK Bose request inxi -Sr

Second edit: I have removed my original install with help of this link: https://anglehit.com/how-to-completely-remove-libreoffice-in-ubuntu-the-command-line-way/

and install it with this link: http://tipsonubuntu.com/2018/08/11/install-libreoffice-6-1-ubuntu-18-04-16-04/ (the 2nd option ppa:libreoffice)

I have accepted that my new LO could break with a new update.... I need my documents now New version : 6.1.1.2 Build ID: 1:6.1.1~rc2-0ubuntu0.18.04.1~lo3

  • 3
    What is "Ubuntu 18.04 Developer Edition". A search turned up nothing. – mikewhatever Sep 17 '18 at 11:29
  • I'll write an answer just a second – JoKeR Sep 17 '18 at 11:48
  • That is the version with only Firefox installation. All other user applications you need to install yourself. fyi I removed Firefox and install Iron Browser – Thuurio Sep 17 '18 at 11:50
  • Install inxi and then post the output of inxi -Sr. – Justice for Monica Sep 17 '18 at 11:58
  • 1
    There's a "minimal" install option but it certainly isn't generally referred to as a "Developer Edition". – Justice for Monica Sep 17 '18 at 12:01
2

Current version supported on Ubuntu 18.04 is 6.0.3.2. You have version 6.0.6.2. Likely, therefore, you are installing it via another software source. Remove the version you installed and remove the third party software source you used in "Software & Updates, "Other software" tab. Then reinstall.

Another possibility is that you have "Pre-release updates" checked on the "Developer options" tab of "software & Updates". If yo did that, then you know you can expect that a certain update may break. If you did that by mistake, again remove your current version and uncheck the checkbox on the "Developper options" tab. Then reinstall.

  • That's a standard issue with Java on all Linux distros. – JoKeR Sep 17 '18 at 11:58
  • 1
    I'm guessing LibreOffice 6.0.6.2 Build ID: 1:6.0.6-0ubuntu0.18.04.1 indicates a ppa. – Justice for Monica Sep 17 '18 at 12:02
  • Hi All, I have removed my current version of LO and reinstall it again with some remarks see my original post – Thuurio Sep 17 '18 at 13:26
2

I am also using the Libreoffice PPA and did an update yesterday (17/09) from 6.0.6 to 6.1.1 (6.1.1.2 Build ID: 1:6.1.1~rc2-0ubuntu0.18.04.1~lo3).
Ran into the issue you mention wherein the UI was corrupted / blank, buttons were missing and unable to create /open any documents. I closed libreoffice, renamed the .config/libreoffice to .config/libreoffice(old). I reopened Libreoffice and issue solved for me.

Possible reason may be incompatible config files, older config files are causing LO 6.1 UI to appear corrupted.

0

Launch LO main window click Tools-->Options-->Advanced and remove a tick Run Java environment

  • Hi JoKeR, When I click on advanced LO main window also shutdown I will try the other solution. Thanks for help so far .... – Thuurio Sep 17 '18 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.