4

Running Ubuntu 18.04, I noticed the problem twice after the kernel was upgraded (standard apt upgrade): a 4K resolution just yields a black screen. It falls back from 3840x2160 to 2560x1440.

After installing Ubunut again, it worked again - until the next kernel update.

Setup: nvidia-driver-390 (proprietary, the one shipped with Ubuntu that seems to be based on version 390.48), NVS 5200M. The video card is quite old, but does 4K at 30Hz. Also Windows worked stable in 4K.

2
+50

Rather than reinstalling Ubuntu after a kernel update, boot with the older kernel.

From the Grub menu, select "Advanced Options" and from there you can select your older (original) kernel that works:

grub-menu.sh

This image generated by grub-menu.sh that displays your grub menu without rebooting. Your real grub menu would look different during boot.

The original kernel version should still work. Then keep trying out new kernels that Ubuntu installs until the bug is fixed. Then after using the most recent kernel you can remove older kernels using:

sudo apt autoremove
  • Thanks, now sure how this helps me with the new kernel? I'd like to stay with it. – Markus Junginger Sep 26 '18 at 7:10
  • @MarkusJunginger You wait for the newer kernel and then try again (with a newer nvidia driver)... I had this a few years back. – Fabby Sep 26 '18 at 17:57
  • The solution didn't work for me, but you're getting the bounty because upvotes indicate that this is helpful for others. – Markus Junginger Oct 2 '18 at 7:54
0

Nvidia drivers have been updated. Please, try with apt install nvidia-driver-396

  • Thanks, unfortunately the 396 dirver did not work with my setup. External screen was not used at all. – Markus Junginger Sep 26 '18 at 7:11
  • 1
    Have you tried to set-up nvidia settings package? sudo apt install nvidia-settings Have you checked if you are using nvidia driver? lshw -c video 2>&1 | grep driver I would also try to check what kernel modules you are using and see if you miss any video kernel. lsmod In case you miss any package, try to install it modprobe module – Vivas84 Sep 27 '18 at 21:34
  • lshw prints configuration: driver=nouveau latency=0 configuration: driver=i915 latency=0 despite I switched to nvidia-driver-390 via Software & Updates -> Additional Drivers. That explains why nvidia settings isn't starting at all... – Markus Junginger Oct 1 '18 at 11:23
  • PS.: I used more current versions from ppa.launchpad.net/graphics-drivers/ppa/ubuntu - but none of those versions seem to work with my set up... – Markus Junginger Oct 1 '18 at 11:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.