1

I've been using Ubuntu for over 10 years now, and am very used to mapping the super key as my language (input) switch (instead of the current default, which is super+space). However, in Ubuntu 18.04 this seems to be not possible; at least not via the Settings > Devices > Keyboard menu. It just wouldn't let you type the super key and accept it as a legit key.

So I went to dconf-editor, and changed it manually to ['<Super>'], but it did not accept it: enter image description here It treated it as disabled.

This is really bad for me. I switch language sometimes 10 times a minute. This is normal behaviour when someone writes technical text in Hebrew, and spread English terms in it. super+space combination is really slow (I compare it with my other computer, which is still 16.04, and in which it was possible to map the super key).

Moreover, even if I can't map the super key, can I at least disable its current mapping somehow? Currently it does exactly what super-s does (fancy presentation of active windows). It is very slow on my computer. I would prefer to do nothing, since now each time I use it by mistake to switch language, I have to wait ~1sec.

EDIT:

After

user@etti:master:.../$ gsettings set org.gnome.mutter overlay-key ""

Tried:

user@etti:master:.../$ gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Super>space']"
user@etti:master:.../$ gsettings get org.gnome.desktop.wm.keybindings switch-input-source 
['<Super>space']

and the super-space combination worked, but tried

user@etti:master:.../$ gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Super>']"
user@etti:master:.../$ gsettings get org.gnome.desktop.wm.keybindings switch-input-source 
['<Super>']

and the super key did not switch input.

  • 3
    I'm not posting this as an answer because it's just a theory. Install gnome tweaks "sudo apt install gnome-tweaks", open it and go to the mouse and keyboard tab. Change the mapping of the activities overview (I improvised a translation from italian, it's the 4th option) from "super left" to "super right", this should free the super button and let it be remapped. EDIT: if it works let me know and I'll post a proper answer to be accepted. – dsSTORM Sep 17 '18 at 7:21
  • Thank you for your comment. First of all, it is wonderful that my super key does not invoke the "overview" as super-s does. super-s is enough. Still, I cannot map the super key to switch input. In dconf it is ['<Super>'], but in the keyboard settings it is mentioned as "disabled", and it really doesn't switch input. – Bach Sep 18 '18 at 18:52
  • 1
    You may find the details of this unrelated, but similar issue helpful, as apparently both GTK and KDE have hidden/hard-to-find Super configurations, inspired by this question. (18.04) – earthmeLon Sep 18 '18 at 19:18
1

I think this command does what you ask for:

gsettings set org.gnome.desktop.input-sources xkb-options "['grp:lwin_toggle']"

(Left Win in Gnome Tweaks)

It seems to override the default behavior of the Super key.

  • Thank you for you answer. This indeed overrides the default behaviour of the super key, answering my question; but it also kills super-s, super-a, super-right, etc. I wouldn't want to do that... – Bach Sep 18 '18 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.