5

I'm running Ubuntu 18.04 with default gnome and I installed Tweaks to change my themes. I'm using theme DMZ White for my cursors.

Everything is OK except for Chromium (Version 69.0.3497.81 (Official Build) snap (64-bit)). The mouse cursor is tiny!

I have checked Slack, Postman, System Monitor and Calculator and the cursor is fine on those apps.

I've tried the instructions here to no avail: Gnome 3: How do I get the same mouse cursors in Chrome?

How can I change my mouse cursor to a normal size in Chromium?

3
  • 1
    @DKBose I have Slack and Postman in my snap directory. The mouse cursor is fine in those applications.
    – rlay3
    Sep 17 '18 at 1:29
  • @DKBose Both system monitor and calculator are also fine
    – rlay3
    Sep 17 '18 at 3:52
  • Maybe related to bug 1700085 of gnome-shell. Set there if the bug affect to you also. In my case happen with Chrome/Chromium and also with Atom. Oct 18 '18 at 23:33
8

I had the same problem with various snap applications. The following solution worked for me:

add the following line to your ~/.bashrc

export XCURSOR_PATH=$RUNTIME/usr/share/icons
5
  • This didn't work for me - but following @rlay3's comment above did work.
    – robocat
    Dec 4 '18 at 22:09
  • Worked with chrome 76 on Ubuntu 18.04 with Gnome Shell. After editing my .bashrc I had to end the chrome process in the system monitor (closing chrome was not enough) and start chrome again. Aug 29 '19 at 7:38
  • Worked in Ubuntu 19.10 (default GNOME) as well.
    – dinvlad
    Dec 1 '19 at 22:15
  • one might want to add it to ~/.profile instead though, otherwise it doesn't always seem to be picked up
    – dinvlad
    Dec 3 '19 at 3:14
  • does not work for Kubuntu 20.
    – rob grune
    Nov 26 '20 at 3:02
5

See my answer to Is there any way to make snap installed apps look more native?. Getting snaps to obey various aspects of the user's theme choices is a work in progress.

More recently, comment #24 related to Ubuntu 18.04 in Graphical snaps don't honour the desktop theme has this:

This is not a uniform bug. Chromium for instance on snap does find the titlebar theme, but not the mouse theme. Gnome Calculator as seen above finds only default theme, but keeps the user choice of mouse pointer just fine.

At this point, all I can advise is patience because the developers are aware of the issue.

2
  • 2
    In case it helps anyone, I uninstalled the snap version and installed the debian version of Chromium from Ubuntu Software (it's the one with the star ratings). The mouse cursor size is fine in that one.
    – rlay3
    Sep 17 '18 at 23:09
  • @rlay3 Thanks - that worked for me (XPS 15 9570).
    – robocat
    Dec 4 '18 at 22:08
0

Are you on a display scale other than 100%? I had mine at 3200x1800 with 200% scale, and my cursor was tiny just on Chrome. I changed to 1920x1080, 100% scale on my main display because I was using a second monitor that only supported that resolution (and apparently gnome or ubuntu doesn't support different scales per monitor?). That fixed the cursor issue for the time being. Maybe try going down to 100% scale and lowering your resolution.

Then, later I was using my laptop without the monitor, cursor was fine, and then I plug in the monitor again, and the cursor is huge on Chrome. This time, "quitting" Chrome and re-opening didn't help, but quitting and killing all the lingering "chrome" processes from ps -ef|grep chrom fixed it.

So there are two possible solutions for particular circumstances. I don't have a general solution, unfortunately.

2
  • use the comment section to post the above matter, not as an answer
    – NIMISHAN
    Nov 29 '18 at 3:21
  • that was my thought but not enough reputation :(
    – slevin
    Nov 29 '18 at 3:28
0

Nor installing official distro deb, nor XCURSOR_PATH helped me. What worked for me was to download chrome instead of chromium from the official Google website: https://www.google.com/chrome/

1
0

For a partial solution, custom cursor, install a google extension to the browser. https://chrome.google.com/webstore/detail/custom-cursor-for-chrome/ogdlpmhglpejoiomcodnpjnfgcpmgale

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.