0

I'm trying to log into my PC running 18.04 with lightDM, and whenever I attempt to sign in, the screen flashes black and returns to my lightDM greeter. If I switch to a different tty and run startx, gnome will start and appears to run fine. I've tried reinstalling lightdm*, which changed nothing, tried gdm3, which would freeze after clicking my user, saying 'authentication error', reinstalling nvidia drivers (affecting nothing), and trying this on a few different users. If I check .xsession-errors, these are the only lines that stand out:

xrdb: Can't open display ''
xhost:  unable to open display ""
xhost:  unable to open display ""

It seems that X/gnome work fine, so I'm not exactly sure where the problem resides.

  • I encountered the same problem when upgrading my Lenovo W541 laptop from 16.04 LTS to 18.04 LTS. None of the usual online solutions to the 'login loop' fixed things. I can login to the full Ubuntu GUI via guest login, but not my main user. Any help would be appreciated. – Kreuzfeld Mar 18 at 22:01

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.