0

Every command I run on Ubuntu 18.04 seems to return this error:

Deprecated Functionality: The each() function is deprecated.
This message will be suppressed on further calls in
/var/www/vhosts/nuovamoda.gr/httpdocs/vendor/colinmollenhour/cache-backend-file/File.php
on line 81

Screenshot of commands

Possibly relatedly, I have in plesk php version 7.0 but in CLI I see 7.2 Any suggest?

4
  • 2
    Tell us more about your system (Ubuntu version, what did you install? ) - and please don't post screenshots of text - edit your question and paste that text.
    – guntbert
    Commented Sep 16, 2018 at 17:08
  • Ubuntu 18.04 i have plesk panel with php 7.0 was php 7.2 magento installed with php 7.0 but my CLI shows me php version 7.2
    – darkattack
    Commented Sep 16, 2018 at 17:13
  • 2
    Welcome to Ask Ubuntu! The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself.
    – guntbert
    Commented Sep 16, 2018 at 18:54
  • Please don't put screenshots of text output. Copy and paste from terminal into the original question using the Edit Question. and format the text output as code using the {_} icon above the edit question window.
    – user68186
    Commented Sep 18, 2018 at 15:27

1 Answer 1

1
Deprecated Functionality: The each() function is deprecated.
This message will be suppressed on further calls in
/var/www/vhosts/nuovamoda.gr/httpdocs/vendor/colinmollenhour/cache-backend-file/File.php
on line 81

That's not an error. It's a warning that each() will disappear in some future version (which is what deprecation means in software).

https://en.wikipedia.org/wiki/Deprecation

While a deprecated software feature remains in the software, its use may raise warning messages recommending alternative practices; deprecated status may also indicate the feature will be removed in the future. Features are deprecated rather than immediately removed, to provide backward compatibility, and to give programmers time to bring affected code into compliance with the new standard.

5
  • as i see 18.4 works with 7.2 php version so i have to downgrade to 16.4 again
    – darkattack
    Commented Sep 16, 2018 at 17:39
  • @darkattack nothing in your question says that the program doesn't work.
    – RonJohn
    Commented Sep 16, 2018 at 17:40
  • well i have troubles with php versions... :S plesk panel shows me 7.0 version of php cli shows me 7.2
    – darkattack
    Commented Sep 16, 2018 at 17:42
  • 1
    @darkattack then the mismatched versions are your problem, not the deprecation warning.
    – RonJohn
    Commented Sep 16, 2018 at 17:44
  • yes i just reinstalled 16.4 will see what will shows me now ...
    – darkattack
    Commented Sep 16, 2018 at 17:56

Not the answer you're looking for? Browse other questions tagged .