Trying to use the Software Updater in 18.04 the usual error returned is

PACKAGE OPERATION FAILED The installation or removal of a software package failed.

I have entered this post several times to point out what I have tried. So summarize, 1. I have shown where I have found posts that I thought were relevant to the Error Message that I received. There are three entries, the earliest one is first and so on. 2. I have shown the lines of code that I have tried and the resulting returns. 3. I would like to thank the person that did edit and nicely format one entry of code. 4. I have just found that the Software Updater fails at the step---APPLYING CHANGES.
September 19, 2018: This is today's trial: Earlier posts follow for September 18 and September 16 Still looking for a cure: from Ubuntu Forum found the following and tried it. The first two lines of code were different from those found previously. Re: Package Operation Failed- The installation or removal of a software package failed https://ubuntuforums.org/showthread.php?t=1935310SO Try entering the following commands in the terminal (close the Ubuntu Software Centre first): Code: sudo apt-get --fix-broken install sudo dpkg --configure --pending sudo apt-get update sudo apt-get upgrade When the lines of code were entered into the terminal, this is the last few lines of what was returned. It took several minutes to get to this. The file names were that appeared were similar to the names of files seen in the Software updater from yesterday. It fails at APPLYING CHANGES.

Fetched 69.3 MB in 3min 41s (314 kB/s)
Extracting templates from packages: 100% Preconfiguring packages ... dpkg: error: info database format (2) is bogus or too new; try getting a newer dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)gus or too new; try getting a newer dpkg

Next the search was for “getting a newer dpkg”, on AskUbuntu, the following link was found. Unfortunately, there wasn’t any new codes or suggestions to be found. s://askubuntuABCD/search?q=getting+a+newer+dpkg

Q: I cant install any new updates i get the error dpkg: error: info database format (2) is bogu…

September 18, 2018--First started trying to solve the problem of PACKAGE OPERATION FAILED: At the end of that post, mentioned that activity bar would run for some time: More details to supplement that comment. Looking again for some other post that had the same problem, it was found:

Thread: Package operation failed message from Ubuntu Forums https://ubuntuforums.org/showthread.php?t=1986644

Here are some things you can try: In a Terminal type the following commands: Code:
sudo apt-get autoclean sudo apt-get clean

then these : Code: sudo rm /var/lib/apt/lists/* -vf sudo apt-get update

After these lines of code were entered; terminal mode was exited and the Software Updater was again run (actually twice).

In the Software Dialog Window, the activity bar showed. Also under the bar was displayed "downloading adobe, firefox and many other words that I just couldn't write down quickly enough...then it showed installing. updates, ...then it showed downloading libmatter, gnome-control, adobe flashplugins, linus image-4.15.0-34-genic, then "extra" then the word flashed up, I think it was "installing" and then the Software Dilog box showed the familar Package operation failed: mentioned in the previous post that it took some time: Well this time, the process took from 5:08pm to 5:15:30; almost 8 minutes until it failed. IT FAILED AT THE STEP----APPLYING CHANGES. I hope these added clues can help someone recognize the cause of this error. Again Thanks

The following was first entered September 16, 2018

From the web found this post at this website How to fix “Package operation failed” Error in Ubuntu https://www.ostechnix.com/how-to-fix-package-operation-failed-error-in-ubuntu/ I opened the Terminal and ran the following commands one by one. Unfortunately it didn't resolve the problem.

sudo apt-get update
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update && sudo apt-get upgrade
sudo dpkg --configure -a
sudo apt-get install -f

Sometimes the Software Updater starts and the activity bar moves about halfway and then results in a lot of material ending in:

Many lines of text and these final lines: Fetched 83.1 MB in 4min 18s (323 kB/s)
Extracting templates from packages: 100% Preconfiguring packages ... dpkg: error: info database format (2) is bogus or too new; try getting a newer dpkg

I have searched the Ubuntu Forum and tried suggestions on how to fix dpkg, but that hasn't worked.

Thank You

1 Answer 1


I have a DELL 9343 XPS running 'Ubuntu 18.04.1'. The first recent indication that I had a problem with the Software Updater was with an update I installed on 31-JAN-2019 when Software Updater returned the message 'package operation failed'.

Looking back at the logs, I found in /var/log/dpkg.log the last three lines indicated that my grub-efi was shown as 'half-configured' but not 'installed'.

2019-02-01 07:03:44 startup packages configure

2019-02-01 07:03:44 configure grub-efi-amd64-signed:amd64 1.93.11+2.02-2ubuntu8.10

2019-02-01 07:03:44 status half-configured grub-efi-amd64-signed:amd64 1.93.11+2.02-2ubuntu8.10

Since I don't like error messages, I began searching for an explanation and for a solution before attempting to remedy the problem. I found that others felt there may be a problem with BIOS file(s) in a permission protected folder /boot/efi.

I found the latest BIOS update '9343_A18.exe' on the DELL support page and downloaded the file. In order to copy the BIOS update binary into the efi partition (/boot/efi) I had to use sudo in the Terminal to copy the 9343_A18.exe file to /boot/efi.

I then followed the instructions to update the BIOS which is to restart / reboot, pressing F12 key in order to enter in the Boot Menu and then choose BIOS Update selecting 9343_A18.exe and choosing to update the BIOS.

After updating the BIOS, Ubuntu Software Updater works fine again without returning any error messages. The last line in the most recent version of /var/log/dpkg.log shows the following documentation that my grub-efi is now shown as 'half-configured' and finally 'installed'.

2019-02-10 05:04:47 configure grub-efi-amd64-signed:amd64 1.93.11+2.02-2ubuntu8.10

2019-02-10 05:04:47 status half-configured grub-efi-amd64-signed:amd64 1.93.11+2.02-2ubuntu8.10

2019-02-10 05:04:49 status installed grub-efi-amd64-signed:amd64 1.93.11+2.02-2ubuntu8.10

After spending considerable time looking into my problem, I concluded that updating the BIOS to the latest version from DELL was the best answer and solved my problem.

Hope this helps anyone looking for a similar answer. Installed systems are of course different. If your problem is different, looking in /var/log/dpkg.log for 'status half-configured' without seeing 'status installed' files may give you a lead on where to look for your own solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .