when googling i find stuff like this: askubuntu resolvconf

but /etc/resolv.conf doesn't seem to exist

sudo dpkg-reconfigure resolvconf

returns that resolvconf is broken or not fully installed

heard 18.04 might be using netplan instead now, but /etc/netplan seems to be completely empty

not sure what to do now, any help would be appreciated

EDIT: running sudo apt install resolvconf asks me to remove openresolv, whatever that is, not sure if i should do that :/

EDIT: /etc/network/interfaces is completely empty aside from loopback interface, can still ping IP addresses tho

  • How did you perform this upgrade? - upgrading should not remove resolvconf. - upgrading should not install openresolv, which is an alternative implementation that has never been supported by Ubuntu. - upgrading should install the netplan package but will not remove ifupdown. - upgrading using any supported method does NOT delete configuration from /etc/network/interfaces. – slangasek Sep 17 at 5:46
  • The short answer should be "you don't need resolvconf on 18.04, /etc/resolv.conf is a symlink to systemd-resolved instead". But it sounds like you have several other things going wrong with your system. – slangasek Sep 17 at 5:50
  • seems like resolvconf was broken, not sure how or why, but reinstalling it manually seems to have fixed it – user301538 Sep 17 at 16:15

If someone encounters a similar issue, here's how i fixed it

download resolvconf.deb manually from official Ubuntu source: http://security.ubuntu.com/ubuntu/pool/universe/r/resolvconf/resolvconf_1.79ubuntu10_all.deb

transfer to Ubuntu PC using USB

sudo apt purge resolvconf
sudo apt install ./resolvconf_1.79ubuntu10_all.deb
sudo dpkg --reconfigure resolvconf
reboot

and then it should be fixed

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.