0

I installed eclipse (sudo apt install eclipse-platform). While running it doesn't open. It gives an error.

"An error has occurred. See the log file /home/usr/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1537079966685.log"

After checking the log file the following shows up---which I don't understand what it's saying--

!SESSION Sun Sep 16 12:09:26 IST 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-09-16 12:09:26.755
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Please Help ASAP

  • Maybe duplicate but there is no solution for this issue, it only says install snap eclipse, that is not the solution as my pc is of low hardware specification so, tried running snap eclipse, it lags a lot. So, I really want to use the old version eclipse as I'm using eclipse for the learning purpose and not for the production. Please support and help. – Pranaya Adhikari Sep 16 '18 at 7:29
  • 1
    And I'm using oracle jdk 8. java version "1.8.0_181" Java(TM) SE Runtime Environment (build 1.8.0_181-b13) Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode) – Pranaya Adhikari Sep 16 '18 at 7:31
  • I have tried with openjdk also it doesn't work. – Pranaya Adhikari Sep 16 '18 at 7:33
  • This answer explains how to change the Java path inside Eclipse IDE (steps 1-9): askubuntu.com/questions/975959/… In fact the linked question has the same error message in it as in this question, so if you can get the correct Java path in Eclipse preferences it might solve this question too. – karel Sep 16 '18 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.