1

I installed kubuntu 18.04 LTS on second hdd(sdb) with lvm enabled and after that am unable to boot to windows first hdd(sda)...if I select windows partition it goes to grub-rescue prompt.

I tried boot repair and boot info url is below :

http://paste.ubuntu.com/p/MWfzwG54cz/

but no success.

sudo fdisk-l

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes

I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disklabel type: dos

Disk identifier: 0x000014e0

Device Boot Start End Sectors Size Id Type

/dev/sda1 * 2048 718847 716800 350M 7 HPFS/NTFS/exFAT

/dev/sda2 718848 973654015 972935168 464G 7 HPFS/NTFS/exFAT

/dev/sda3 973654016 974575615 921600 450M 27 Hidden NTFS WinRE

/dev/sda4 974575616 1953521663 978946048 466.8G f W95 Ext'd (LBA)

/dev/sda5 974577664 1851121663 876544000 418G 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes

I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disklabel type: gpt

Disk identifier: 4A402D48-494A-4846-B971-C568427BBB95

Device Start End Sectors Size Type

/dev/sdb1 2048 1050623 1048576 512M EFI System

/dev/sdb2 1050624 1953523711 1952473088 931G Linux LVM

Disk /dev/mapper/kubuntu--vg-root: 930.1 GiB, 998638616576 bytes, 1950466048 sectors

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes

I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/mapper/kubuntu--vg-swap_1: 976 MiB, 1023410176 bytes, 1998848 sectors

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes

I/O size (minimum/optimal): 4096 bytes / 4096 bytes

ls /sys/firmware/efi/

config_table efivars fw_platform_size fw_vendor runtime runtime-map systab vars

If I try

sudo os-prober

it returns nothing.

Any help will be greatly appreciated.

Thanks.

  • Update 1 : I found a bootable windows USB drive and tried the following commands : – user871869 Sep 18 '18 at 3:16
  • Update 2 : I found a bootable windows USB drive and tried the following commands : bootrec /RebuildBcd, bootrec/fixMbr, bootrec /fixboot and also bootsect /nt60 SYS and bootsect /nt60 ALL. Still no success. After doing all this ran boot-info : paste.ubuntu.com/p/5MTmHrQhf7/......There is a different message : Windows is hibernated, refused to mount. Falling back to read-only mount because the NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting.) Any ideas....Thanks. – user871869 Sep 18 '18 at 3:27
  • After some research the issue seems to be related following bug : bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1767889 Will wait for bug to be fixed.....hopefully soon. – user871869 Sep 22 '18 at 4:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.