0

My system has been frequently locking up since upgrading to 17.10 and it appears to be that xorg it taking the processor to 100%. I purged the NVidia drivers but can’t reinstall as countless files and folders appear to be locked. Stuck in terminal now.

Using dpgk-reconfigure lightdm

Gives choices of gdm3 and lightdm but selecting lightdm indicates

Cannot move ‘/etc/X11/default-display-manager’ to ‘/etc/X11/default-display-manager.dpgk-tmp’

After remounting the drive with write permissions, I purged nvidia again and also lightdm, then reinstalled nvidia and now it gets passed the terminal login prompt, then shows a long list of starting items but stalls at GNOME display with ‘Started GNOME Display Manager.enerate Color Profiles...tem changes.pp link was shut down.

I just rebooted and it got to the same place where it hung but the error is slightly different with dots between and inside words. In other words, similar error but broken up differently so it appear that the error itself is not being presented properly.

It appears that networking is no longer available on the system as the drivers must have uninstalled along with the NVidia graphics drivers. It never occurred to me that the network drivers were also NVidia! Is there a way to reinstall them without a connection by downloading using another PC, then copying over the files? What is the process and which files should I download? Mine uses the 340 drivers.

  • How about sudo dpgk-reconfigure lightdm? – mikewhatever Sep 15 '18 at 21:35
  • Yes, that was many of the countless things I’ve tried. Since I’m posting this problem using my iPad I’ve not been able to drop in everything I’ve tried but basically I went through all the posts here and elsewhere and tried most everything. I’m hoping someone here might think of something else. – DonP Sep 15 '18 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.