1

I have a Windows guest setup using KVM on an Ubuntu host. The problem is that I am able to connect to the internet and ping the host from the guest, but can't seem to ping the guest from the host or any other machine from my network. I have set up a bridge 'br1' to use my ethernet interface 'enp0s31f6'. Here is my /etc/network/interfaces config.

auto br1
iface br1 inet dhcp
 bridge_ports enp0s31f6
 bridge_stp on
 bridge_fd 0.0

Below is the output of ifconfig

br1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.1.4  netmask 255.255.255.0  broadcast 192.168.1.255
    inet6 fe80::127b:44ff:fe15:f37d  prefixlen 64  scopeid 0x20<link>
    ether 10:7b:44:15:f3:7d  txqueuelen 1000  (Ethernet)
    RX packets 739277  bytes 1058869416 (1.0 GB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 693983  bytes 54242599 (54.2 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    ether 10:7b:44:15:f3:7d  txqueuelen 1000  (Ethernet)
    RX packets 22782265  bytes 33307625462 (33.3 GB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 20737125  bytes 10650592233 (10.6 GB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    device interrupt 16  memory 0xdf200000-df220000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 209286  bytes 376780337 (376.7 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 209286  bytes 376780337 (376.7 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet6 fe80::fc54:ff:fe99:3ed6  prefixlen 64  scopeid 0x20<link>
    ether fe:54:00:99:3e:d6  txqueuelen 1000  (Ethernet)
    RX packets 583200  bytes 40164778 (40.1 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 784791  bytes 1164555387 (1.1 GB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0 is setup by KVM on running the guest. The guest is being detected by the router under a separate device and the DHCP on the router does allocate it an IP.

IP Address: 192.168.1.35
Subnet Mask: 255.255.255.0
Gateway: 192.168.1.1
DNS: 192.168.1.1

I have gone through dozens of solutions from google but nothing seems to work. Any help would really be appreciated.

0

The scenario you describe is a guest that is connected on a bridge so it gets an address on the local LAN - probably 192.168.1.xxx.

Please note your guest address (run ipconfig in windwos or get the address from GUI). This is probably the address from the DHCP server.

Communication between your host and guest (or any other computer on the LAN and the guest) should be possible but may be blocked by the firewall on the destination.

First thing I would try is to check the connectivity: 1. Can you access the web from the guest? 2. Can you ping the router from the guest? 3. Can you ping the guest from other computers on the LAN? 4. Can you ping the guest after disabling the windows firewall?

The above should give clues that will help resolve the communication. Good Luck

  • 1. I can access the internet from the guest. 2. I can ping the router and every other machine on the network from the guest. 3. Can't ping the guest from the host or any other machine on the network. 4. Pinging to the guest works fine if I disable the firewall on guest. But this is weird, not sure if it is a virtualization thing, but this is the first time I have seen a windows firewall block pings. – Ranjith R Shenoy Sep 15 '18 at 19:07
  • Seems like the communication works well and it's all about setting the windows firewall. You probably want to start by allowing things like SSH (install cygwin and ssh server on windows), and enable remote desktop (to connect with remmina from your linux host. You should probably look at the way your LAN is define - public, private etc. in your windows box. – user1656671 Sep 15 '18 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.