4

Today I installed kubuntu 18.04 on my laptop, and I'm having some problems with it. One of the problems is the high temperature of two chips. When running the command sensors in the terminal I get the following output (at idle):

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +44.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +44.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +44.0°C  (high = +100.0°C, crit = +100.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1:        +46.0°C  (crit = +120.0°C)

iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +60.0°C  

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +60.0°C  

The last two devices have a 60.0°C temperature, and it seems the chips are located under the keyboard to the left because that region feels really hot and makes it annoying to type or to place my hands above the keyboard. Is it possible to bring these temperatures down?

I'm already using tlp, and thermald came preinstalled in the system.

EDIT: The laptop is a Gigabyte Sabre 17 with an i7-7700HQ processor. Here are its details using Speccy on my Windows 10 partition: enter image description here

2
0
+50

sensors reads information from the kernel and sometimes it seems a bit off. To confirm you do have a problem read the information directly from the kernel yourself with this command:

$ paste <(cat /sys/class/thermal/thermal_zone*/type) <(cat /sys/class/thermal/thermal_zone*/temp) | column -s $'\t' -t
INT3400 Thermal  20000
SEN1             54000
SEN2             51000
SEN3             58000
SEN4             61000
pch_skylake      -44500
B0D4             49000
x86_pkg_temp     51000

There are three implied decimal places so the actual temperature of X86_pkg_temp is 51.000 Celsius. As you can tell from the pch_skylake sensor a temperature of -44.5 is out to lunch. I've noticed this one sensor is often out of wack.

Hint: Copy and paste the terminal command after the $ sign into your terminal and press Enter instead of laboriously typing it in.

5
  • Thanks for the answer, though this method is giving the same readings as sensors in my case. And I don't know why is it a sky-lake sensor in a kaby-lake chip. – Tofi Sep 22 '18 at 10:40
  • Your temperatures aren't really that hot. You might bring them down about 10 degrees if you have a nVidia graphics card and disable it to use Intel built in GPU instead. If your BIOS can force fans on all the time it will also bring temps down at the expense of more noise and shorter battery life. As far as Kaby Lake is concerned, that portion of the chip is based on Sky Lake technology I guess. – WinEunuuchs2Unix Sep 22 '18 at 10:58
  • Unfortunately my Nvidia card causes a lot of screen tearing in the Plasma desktop and it goes really hot even if I use it with optirun for a very lightweight game, so I'm only using the Intel gpu already. – Tofi Sep 22 '18 at 11:14
  • I had problems with the nVidia 390 drivers in 18.04 so I used the 384 drivers instead. You might want to try that later. – WinEunuuchs2Unix Sep 22 '18 at 11:22
  • @WinEunuuchs2Unix there are other reports of over-temp with this PCH, etc., including a report of a fix by using alternate driver for wifi as I linked above. – pbhj Sep 22 '18 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.