0

I am trying to re-partition & reinstall my existing Kubuntu installation on my MSI GL62 6QF laptop (upgraded with 32GB ram since last install).

I can see the Kubuntu choice screen without giving any options. Kubuntu choice screen

But if I click on "Try Kubuntu", the system just freezes up.

I overcame this issue by using the nomodeset boot parameter. However, the setup just stops at the next screen. Splash screen after Try Kubuntu with nomodeset

Here's the same step without quiet splash. Screen after Try Kubuntu with nomodeset and without quiet splash

So far, I've tried.

  • Toggling CPU C States option
  • nouveau.modeset=0
  • pci=nomsi
  • acpi_osi=Linux

Also, I'm on Legacy boot mode, as the USB is never booting in any other modes.

Maybe unrelated, but the USB only boots properly in one USB port (USB2vs3 issue).

Edit: Additionally, here's all my BIOS options: BIOS Advanced tab screen BIOS Boot options tab screen

1
  • In the grub menu try quiet splash acpi_osi=! acpi_osi='Windows 2009'
    – Tofi
    Commented Sep 15, 2018 at 12:36

3 Answers 3

0

Go to BIOS and disable your graphics memory, and try again.

1
  • There's no option for that. You can check for yourself in my edited question.
    – fayaz
    Commented Sep 15, 2018 at 11:49
0

You can try to disable secure boot

1
  • There's no option for secure boot. I've edited my question to show all BIOS boot settings.
    – fayaz
    Commented Sep 15, 2018 at 16:00
0

Use only acpi=off.

Turns out nomodeset is totally unnecessary (harmful) and even nomodeset acpi=off halts the booting for this laptop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .