0

A few months back I installed Ubuntu for the first time on a new laptop and started getting accustomed to it. After doing the initial setup and installing nvidia drivers for my dedicated gpu I encountered a bug that would cause the drivers to not unload properly once prime-select was switched to intel.

https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1778011

Now as I'm looking at this, and correct me if I'm wrong, the bug seems to be resolved.

Does that mean that I have to install nvidia-390 and that will contain the bugfix or do I need to install a different driver?

Nvidia-396 which seems to be the latest stable driver returns a not found when trying to install from terminal.

Using ubuntu 18.04.01 LTS

Here's the output of inxi -G

Graphics:  Card-1: Intel UHD Graphics 620
           Card-2: NVIDIA Device 1d12
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.98hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
           version: 4.5 Mesa 18.0.5
10
  • See askubuntu.com/a/1070682/231142 for installing the 396 driver into Ubuntu. If you are using 18.04, the driver is listed there in the link. If you are using 16.04 the driver name would be nvidia-396
    – Terrance
    Sep 15 '18 at 3:10
  • I tried doing that, but I get these errors back, not sure what they mean textuploader.com/dvmwp
    – creativiii
    Sep 16 '18 at 13:35
  • It means that the PPA is not setup properly. What version of Ubuntu are you using?
    – Terrance
    Sep 16 '18 at 13:45
  • I'm on 18.04.01, everything is up to date
    – creativiii
    Sep 16 '18 at 14:55
  • Please try redoing the PPA. Something is not set up right. I have 18.04.1 and the drivers were easily installed through that link I posted. I forgot to ask, what video card do you have?
    – Terrance
    Sep 16 '18 at 15:06
1

I figured out a fix.

While having nvidia-390 installed I couldn't install nvidia-driver-396 as the terminal would just spit out errors that I couldn't fix.

The newest drivers refused to download and install until the point where I ran

sudo apt remove nvidia-390
sudo apt-get purge nvidia*

(I also ran sudo apt-get purge bumblebee* since I wasn't sure if that had installed anything related to nvidia)

Once that was done I ran

sudo apt-get install nvidia-driver-396

And it worked perfectly. I still can't see the name of my video card in Ubuntu itself, but everything seems to be working just fine.

0

the bug seems to be resolved.

It looks as though it was resolved but not yet released:

"I hope we can finally get ubuntu-drivers-common into bionic-proposed now"

You can try out the version of nvidia-390 he uploaded to the PPA.

2
  • How would I install the version he uploaded to the ppa?
    – creativiii
    Sep 16 '18 at 13:36
  • sudo add-apt-repository ppa:albertomilone/hybridgraphics Sep 16 '18 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.