I had a pre-installed Windows 10 in my Laptop. I had decided to install Ubuntu 18.04 by creating a partition in the single hard disk. Everything worked like a charm for two months without any problem. I had the boot menu that would allow me to select between Windows 10 and Ubuntu.

Last week on a fine day, after I shut down my computer and switched it back on, selecting Ubuntu showed grub failure screen. It was not loading Ubuntu at all. Then I decided to use boot-repair which automatically did some recommended repairs. Now, the issue is that the boot menu is no longer available and the system boots directly into Windows 10.

I am not sure if this is relevant but many solution involved UEFI mode for BIOS, but I have come to know that upon typing msinfo32 in Run Command in Windows 10, it shows the BIOS mode as "Legacy".

I made a bootable Ubuntu USB and entered Ubuntu using "Try Ubuntu". The hard disk portion where I installed Ubuntu i.e. /dev/sda6 is still available. I am not sure if it's corrupt.

I tried implementing "bcdedit" as well but still it's going directly into Windows 10.

I was hoping if someone can help me with this issue.

New contributor
Naseef Ummer is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • try update-grub. See if that works. – ARTube Sep 14 at 16:15
  • Do I have to go in via "Try Ubuntu" using bootable USB? – Naseef Ummer Sep 14 at 16:16
  • 1
    yeah sorry to mention that! – ARTube Sep 14 at 16:19
  • I also noticed that the filesystem for the partition containing "Linux" is showing as RAW when using Ext2 Volume Manager tool. Isn't it supposed to be "ext2"? Did it get corrupted? I don't know if Windows updated during my last shut down. – Naseef Ummer Sep 14 at 16:25
  • It should be ext4, but some Windows third party tools may not see it correctly. Windows does not recognize Linux formats at all. RAW is unformatted in Windows. You should use Ubuntu live installer to review partitions or make Linux repairs. Use Linux tools for Linux and Windows tools for Windows. – oldfred Sep 14 at 21:27

Set your BIOS back to UEFI booting, for Windows 10.

Make sure Windows still boots.

See Rod Smith's answer here, and use the bcdedit method to fix your problem.

  • bcdedit did not work. How do we set the BIOS back to UEFI mode? I can't find it in my BIOS. It's in the Legacy mode. – Naseef Ummer Sep 15 at 18:12

Your Answer

Naseef Ummer is a new contributor. Be nice, and check out our Code of Conduct.
 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.