I would appreciate someone interpret for me what the terminal run means. I've edited it for brevity.

  1. I first ran "$ sudo fdisk -l ". Then I attempted to make a directory.
  2. Then I attempted to make a mount point " $ sudo mkdir /media/USB ", which I tried previously, also, which might explain "File exists."
  3. The I attempted to mount the USB drive, following a cookbook at http://sourcedigit.com/14779-mount-unmount-usb-pen-drive-ubuntu-terminal/ . The result said it was already mounted or busy. so...
  4. I attempted to unmount it, if that were the problem "$ sudo umount /dev/sdd "
  5. Then I repeated the make directory and mount commands. It again told me it was already mounted or busy.
  6. I then finished by attempting to leave it in a unmounted state.

gparted then gave me me a dropdown box: /dev/sdd (7.5 GiB) The green box portion above the partitions says " /dev/sdd2 7.5 GiB " The partition portion of gparted has three lines. The first is: "/dev/sdd1 (exclamation point) File system (black square) unknown Size 31.50 KiB The second is: unallocated , File System grey square Size 1.97 KiB The final line is: /dev/sdd2 key symbol File system (green square) fat32 Mount Point /media//1D7E-DAFB Size 7.5 GiB Used 14.99 MiB Unused 7.48 GiB

Am I in error attempting to mount /dev/sdd ? Should it be one of the partitions?

  • You've got a 31k partition sdd1, 2k of empty space, then 7.5G in sdd2? Why the tiny sdd1? Why the fdisk? Tried mount|grep /dev/sdd? Or just use Disks / gnome-disk-utility, or the built-in file manager?
    – Xen2050
    Sep 14, 2018 at 1:48
  • I don't know why I had small partitions - it was likely something I did accidentally yesterday. Yes, thanks, Disks GUI is a better way for me. I reformatted the USB with it and now gparted agrees, with one unallocated partition, unallocated File System, of 7.5 GiB size. Now I'll do it again with FAT32 and see if my cookbook mount/umount will work. I checked the Man page for Mount but I don't completely understand it yet.
    – JWNWSA
    Sep 14, 2018 at 4:42
  • Mount is a rather large program, about 2 thousand lines in the man page, but there's lots of different sections for different filesystems so only the general stuff & vfat (fat32...) should apply, but just look up the bits you're interested in. Anyway if Disks is a good answer, do remember to upvote &/or green-check (pick correct) it.
    – Xen2050
    Sep 14, 2018 at 5:00
  • Edit: I reformated to FAT32 in Disks and now gparted indicates one line: "/dev/sdd (exclamation point) File System fat32, and it is mounted, just not to the point I had specified. It has the label I assigned, the size, the used portion (overhead?) of 15 MiB and the unused size. Thank you - the question is answered.
    – JWNWSA
    Sep 14, 2018 at 5:05
  • Welcome :) Sounds like it might be unpartitioned now (everything's just on sdd, no sdd1, sdd2, etc), but that should work good too
    – Xen2050
    Sep 14, 2018 at 6:49

1 Answer 1


Am I in error attempting to mount /dev/sdd ? Should it be one of the partitions?

Yes, your drive sdd (like most drives) is partitioned. Unpartitioned drives do exist, but aren't very common, and make things harder to change/move in the future.

PS. there are good GUI's for this stuff, like Disks / gnome-disk-utility, try it instead. Or lsblk is handy too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.