I just installed Ubuntu 18.04 on my ASUS X555LA. I was using Windows 10 and everything worked kinda fine, but I've been having some troubles with my connection since I installed Ubuntu.
At first, it wouldn't recognize the wireless card and I couldn't connect to the wi-fi (my card is a MediaTek MT7630E). After doing some research, I could finally fix it. Now, the problem is: even though the wi-fi works fine, the connection is still EXTREMELY slow. Like, 100 kb/s. It should be around 10-20 mb/s. I couldn't find any solution on Google.
Could you please help me?
Here's the output of sudo lshw -C network

   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 10
   serial: 1c:b7:2c:9d:8e:11
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:18 ioport:3000(size=256) memory:b2104000-b2104fff memory:b2100000-b2103fff

   description: Wireless interface
   product: MT7630e 802.11bgn Wireless Network Adapter
   vendor: MEDIATEK Corp.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0f0
   version: 00
   serial: 40:b8:9a:76:7b:dd
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=mt7630e driverversion=4.15.0-34-generic firmware=112.3 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:19 memory:b2000000-b20fffff

Thank you!

  • Welcome to Ask Ubuntu! Add the output of iwconfig wlp4s0 to your post. If wlp4s0 isn't your wlan card, find it with ip l, and replace it. – abu_bua Oct 20 '18 at 15:25

Uncheking "Make available to other users" in the settings of the network you are connected has worked for me.

  • Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – abu_bua Oct 20 '18 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.