0

I tried to increase swap size.

and then had those problems

After restarting, swap becomes 0 gb

but solved the temporary swap size problem.

Normally it took 3 seconds to open laptop but now it takes 1-2 minutes to open. It started after that resizing.

I dont know what i broke. I can post output of anything if you need.

% free -h                                                                                                                                                                                           
              total        used        free      shared  buff/cache   available
Mem:           7.7G        6.0G        945M        118M        731M        1.2G
Swap:           10G        1.9G        9.1G

And when i hibernate and wake up, black screen comes

  • It would be interesting to indicate in that other question how you solved the problem. Was the answer there adequate or did you solve in another way? The idea is that you may find help here, but you should also share back to the site, and in particular to other users that may have a similar issue. – vanadium Sep 14 '18 at 9:47
  • I wrote as comment. askubuntu.com/questions/194775/… i did this. Also someone posted simlar solution. – vegan Sep 14 '18 at 11:34
  • Thank you. Sorry, I missed the command. You swapon suggests that at least the swap is fine. Also the size is fine. Note however that hibernate does not work well in linux on many hardware. Can you see if the startup problem persists if you startup and fully shut down a few times in a row? Next, check whether the problem is still there after you disable swap in fstab (put comment sign # in front of the line). – vanadium Sep 14 '18 at 12:26
  • @vanadium i restarted lots of times. Now it is better but before it was 3-4 sconds. now 6-7 seconds but it is ok. Now only hibernate is probllem. maybe i should remove it totally – vegan Sep 15 '18 at 11:13
  • That is better and shows it may have had to do with some initialisation of swap during startup. Indeed, unfortunatelly, usually the recommendation is to disable hibernation in case it does not work reliably. Sleep, where the computer is put in a very low power mode, but all is kept in memory, works better on more hardware. – vanadium Sep 15 '18 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.