I have a dual boot configuration, with grub2 prompting the boot list when I switch on the PC. The systems installed are Ubuntu 16.04 and windows 10.
My PC went off while windows was installing the automatic updates. When I restarted, I logged-in Ubuntu and upgraded it from 14.04 to 16.04 (this was planned since weeks..). Now booting windows does not work any longer and the system freezes with the windows logo on the screen. I need to recover windows from a bootable windows cd, which I have. However when setting in the BIOS to boot the DVD drive first, this command is ignored and grub2 keeps appearing.

I did the following:

gksu gedit /etc/grub.d/40_custom

and added these lines to the file:

menuentry "CD on (cdrom/dvd)" {
    set root=(cd0)
    insmod part_gpt
    insmod chain
    chainloader /boot/efi/EFI/ubuntu/grubx64.efi    
}

and finally

sudo update-grub

After that, grub2 correctly shows the option "CD on (cdrom/dvd)". However when I select it, I get an error message showing that /boot/efi/EFI/ubuntu/grubx64.efi cannot be found (although the path is existing).

Any idea on how to solve this is greatly appreciated! Thanks!

Problem solved. I noticed that in the BIOS boot menu there was an option called "Boot menu" that was disabled. I had to enable it and place it as first option. When restarting, the default boot menu allowed me to boot from DVD. Cheers.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.