2

https://paste.ubuntu.com/p/5JNQJsFTBR/

The above URL is taken from my boot-repair tool's report.

I'm new to Linux. I have a laptop computer with 2 hard drive. One is a 1TB ordinary hard disk drive while the other is a 256GB SSD drive. I installed Windows 10 on the SSD drive(sdb).

I'm using UEFI boot and Secure Boot is enabled. At the moment I would prefer keep using UEFI and keep secure boot enabled unless it's really necessary to change them.

Then I want to install Ubuntu 18.04LTS to get dual boot. During installation I chosed manually partitioning and installed Ubuntu 18.04 into the ordinary hard disk drive(sda). I created 2 partitions, one of which is swap area, and the other is for / (root directory). I did not created any other partition for Linux but I pointed the linux boot loader to the Windows EFI partition(in sdb).

However after installing Ubuntu 18.04 and restarting the computer, there is no grub boot loader showing up and the computer boots directly into Windows 10. I have checked the BIOS, even there is not a Ubuntu/Linux boot option to choose in the boot priority order in BIOS.

I have tried the boot-repair tool (https://help.ubuntu.com/community/Boot-Repair) but it doesn't fix it, even though it says "Boot succesfully repaired". Hence I upload the boot info to the above URL.

Since I'm new to linux, this has driven me crazy today, please help! Thanks in advance

  • Need to see output ofsudo parted -l. Firstly, I would disable secure boot. Secondly there should be a boot/efi partition created automatically on sda when you install Ubuntu. I'm not sure what you mean by 'pointed linux bootloader' to that on sdb disk. How did you do that? Thirdly, go into BIOS to check if an Ubuntu boot option exists and if so it should be first option. – Paul Benson Sep 13 '18 at 17:36
  • Thanks for reply. Firstly, I found that many people use secure boot with linux successfully. Secondly my windows was installed before linux, and it is installed in sdb, so there is a windows efi paritition in sdb2. So during installation when the ubuntu 18.04 installation guide ask me "device for boot loader installation", I chose sdb2. That's what I mean by "pointed linux bootloader" to sdb. Even if this were wrong, I used boot-repair tool after that, which I think would automatically fix the grub installation. Thirdly, I did go into BIOS, but there is no Ubuntu boot option whatsoever. – Wei Sep 13 '18 at 18:39
  • I see mention of Acer video. Is this an Acer and what model? All Acer have an unique requirement of setting "trust" of the grub/ubuntu .efi boot files. Many Acer also need UEFI update from Acer to have trust setting. See: Trust settings in step 35 askubuntu.com/questions/627416/… Also you have fast start up on which is hibernation: askubuntu.com/questions/843153/… – oldfred Sep 13 '18 at 20:45
  • Yes my computer is Acer, I also just heard that there is some special "trust" setting in UEFI for Acer computer to work properly with ubuntu. I will try that later if converting my sda disk(using MBR) to GPT does not fix my issue. – Wei Sep 13 '18 at 20:57
1

Found the solution, as oldfred said, this is caused by Acer UEFI firmware "trust" settings.

I followed instructions in the following posts and fixed the issue:

https://ubuntuforums.org/showthread.php?t=2358003

https://ubuntuforums.org/showthread.php?t=2401105&p=13800621#post13800621

Thanks for help from everyone.

|improve this answer|||||
0

If you look at line 1270 in your pastebin it tells you to disable 'secure boot'. But that's not the main reason for your issue.

Looking at sda that is configured as an MBR disk, whereas sdb is shown as a GPT disk. You cannot use the 2 alternative formats simultaneously. If your BIOS is enabled as a 'UEFI' it will not recognize disk sda. Vice-versa if BIOS is enabled as 'Legacy' it will recognize the sda disk, but not sdb.

So your BIOS is UEFI enabled and can read the SSD partitions (gpt) on sdb where Windows is installed, but cannot read the sda (MBR formatted) disk where Ubuntu is installed.

The remedy is to convert sda to GPT configuration. Normally you would lose all data on that disk when you convert it. But there is a software tool that claims that you can avoid that problem, but I've not used it so cannot vouch for its safety. I would then reinstall Ubuntu after that. Once installed you need to go back unto BIOS and ensure that Ubuntu is shown as first boot priority.

|improve this answer|||||
  • I have seen one or two Summary reports with mixed gpt & MBR booting in UEFI boot mode. But UEFI highly recommends gpt and Windows only boots in UEFI mode from gpt. Ubuntu can use MBR but not recommended. – oldfred Sep 13 '18 at 20:39
  • Ubuntu can use MBR of course but on its own, not in a multiboot wuth a GPT drive. Remember that other guy, AndroidDragon from a few hours ago had the same issue. He converted one of his boot (MBR) drives to GPT and issue was solved. – Paul Benson Sep 13 '18 at 20:45
  • This is definitely not true, you can use MBR and GPT disks simultaneously. – mook765 Sep 13 '18 at 20:47
  • Thanks for reply. I'm not sure whether you are right because my windows can operate on the MBR disk properly. But I will give it a try. Thankfully there is no huge data in my sda disk and I would just back up the data, covert the disk and have a go. I'm looking for the result. – Wei Sep 13 '18 at 20:49
  • @mook765. Well it won't work on my computer I can assure you. GPT is compatible with UEFI, whereas MBR is not. I thought that was pure basics. – Paul Benson Sep 13 '18 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.