I'm new to Ubuntu and I've 18.04 installed. Not sure if this is due to faulty installation or something, but I'm having trouble with very slow Wi-Fi speeds and frequent disconnections. Here is a pastebin link to diagnose my issue, important info as follows:

##### kernel ############################

Linux 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=1

##### lspci #############################

08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Kernel driver in use: rtl8723be

09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
    Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller [103c:8096]
    Kernel driver in use: r8169

Any help is greatly appreciated. I've started a new project in college and need to use Ubuntu. If it helps, I'm using a HP Pavilion Notebook (M2W75PA#ACJ).

So far, I tried disabling 802.1n band. Unfortunately, it didn't help me much.


In your pastebin, we see this:

options rtl8723de ant_sel=1

You haven’t any rtl8723de device; yours is an rtl8723be. They are two different devices. Let’s remove the needless file:

sudo rm /etc/modprobe.d/rtl8723de.conf

We also see this:

options rtl8723be ant_sel=2
options rtl8723be 11n_disable=1

11n_disable is not an available parameter in the driver rtl8723be. Confirm:

modinfo rtl8723be

Let’s remove the needless declaration:

sudo nano /etc/modprobe.d/rtl8723be.conf

Remove the 11n line so that the file now only contains:

options rtl8723be ant_sel=2

Save (Ctrl+o followed by Enter) and close (Ctrl+x) the text editor.

We also see:

Cell 01 - Address: <MAC '301 Th' [AC1]>
                    Frequency:2.452 GHz (Channel 9)
                    Quality=54/70  Signal level=-56 dBm  
                    Encryption key:on
                    ESSID:"301 Th"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 60ms ago
                    IE: WPA Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

I have worked on several cases where removing a space in the name of the SSID improved connectivity. If this is a router for which you have administrative privileges, I suhhest that you rename it to 301Th or 301_Th or some such without a space.

Next, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Please see this interesting post about the unreliability of auto channel select: https://superuser.com/questions/1311149/why-do-wifi-routers-do-such-a-bad-job-of-channel-selection

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:


Proofread carefully, save and close the text editor.

  • Thanks! It Worked. I can't thank you enough. But there is one small problem. I seem to get full download speeds (100Mbps) only when I'm sitting right next to the router. The second I move to my room, barely 5ft and behind a wall, the speed drops to 10Kbps. I don't have this problem in Windows 10. Again, thank you for your help. – notDarkMatter Sep 13 '18 at 15:44
  • Please edit the rtl8723be.conf file to show ant_sel=1 , reboot and tell us if there is any improvement. – chili555 Sep 13 '18 at 16:32
  • Hi, it didn't work. So i went ahead and bought a wifi dongle. Now I have no issues. Really appreciate the help. Thank you. – notDarkMatter Sep 18 '18 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.