5

I had a working 16.04 working perfectly (but no bumblebee) and then upgraded to 18.04. Gnome was very laggy so I installed Unity and lightdm but it was still laggy. So I thought something was wrong with video drivers. So I purged nvidia and installed nvidia-driver-390, but I also tried to install bumblebee.

Then I reboot and startup stops with a PKCS#7 signature not signed error. I got into recovery console and removed nvidia-driver-390, but I'm still getting that same error. Had trouble enabling networking, as it would just hang and not return to recovery menu.

Any ideas what's wrong and how I can fix it? I'm thinking about running Nvidia binary installs but my home directory was encrypted and I had to give up last night. Anything else I can do?

7
  • Have you tried disabling SecureBoot in the BIOS? – Terrance Sep 13 '18 at 13:53
  • Yes, as far as I can tell SecureBoot is disabled. I think I needed to disable it when I first installed Ubuntu 16.04 last year or so. – Jbrodog Sep 13 '18 at 16:35
  • So, I was able to recover by going into recovery and apt purge nvidia* && apt autoremove. Then I installed the nvidia-driver-396 package and everything seemed to work after reboot. But then I tried (github.com/timrichardson/Prime-Ubuntu-18.04) and prime-select intel which killed my lightdm session and hung my system, and then on reboot, ended up with the same original PKCS#7 signature not signed error. – Jbrodog Sep 14 '18 at 3:36
  • Maybe try installing the NVIDIA drivers into 18.04 this way: askubuntu.com/a/1070682/231142 – Terrance Sep 14 '18 at 3:38
  • Yeah I've done this again and don't seem to have issue running nvidia-driver-396. I think my issue is something with the nvidia prime switching to intel. Maybe something with nvidia drm. – Jbrodog Sep 14 '18 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.