0

When I type shutdown -r now or reboot in terminal, after shutdown the notebook power is on (power indicator is on and keyboard light is also on), but no display at all (screen is off). No ASUS logo, no grub menu, nothing, just black screen.

However, if I just type shutdown -h now, waiting notebook turn off, then click power button, grub menu can appear and Ubuntu can normally startup.

I don't know why.

I also tried different suggested GRUB config, and all possible options on BIOS, doesn't work as well.


Edit:

I tried to see if there are some useful information in syslog, but nothing here:

syslog

seems like the reboot process even not go through to the point where logs can be written to the system.

0

This is a guess, but my thinking is that Linux’s support for something on the motherboard of this computer isn’t perfect. It could be a BIOS/ACPI issue or something else. Since you have a work-around, I’d just make sure your kernel is the latest version. From a terminal:

apt list —upgradeable | tee - ./package-update-list | grep linux-image

will tell you about any kernel updates that are available, while saving the list of all available packages to package-update-list. You might get an error message about using apt in scripts, but the above isn’t making any changes — it’s just showing you what can be upgraded, so no worries.

Maybe a simpler command would be:

apt list —upgradeable linux-image*

Which I’ve just verified works. If you want to upgrade your kernel you’ll need to type:

sudo apt upgrade linux-image-generic

The “generic” gets added so you’re running the most stable/production kernel. There are 100’s of different kernel types if upgrading to the latest generic kernel doesn’t work, one of the other linux-image files might. But I definitely wouldn’t try one at random as it could cause serious problems. Someone with better kernel-fu would have to answer that.

The above command of will probably require updating 100’s of packages. I’m doing it now and 200+ are installing :)

The newest version I see is linux-image-4.15.0-34.37.

jmitchel@MontyPython:~$ uname -a
Linux MontyPython 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

One more thing. The command "dmesg" might provide you with some clues. Look for things in red :)

dmesg | more

or

dmesg | grep ACPI

or

dmesg | reboot

Finally, if there's a critical problem when rebooting, it might get logged via syslog. It would probably be in /var/log/syslog. So:

tail -"n" /var/log/syslog | more

Where n is the number of lines you want to see, starting from the end of the /var/log/syslog and going backwards. So

tail -50 /var/log/syslog | more

Will show you the last 50 lines of /var/log/syslog

So if a new kernel doesn't help, do the following

date
reboot

Then, when you get back into the system, log in and type the following

more /var/log/syslog

Then press / to search and type in the time when you rebooted. For example

Sep 14 03:00

would take you to the place in the file which has an entry containing an entry containing "Sep 14 03:00". All entries in /var/log/syslog start with a timestamp.

And the command:

ls -alt /var/log | more

will show you which files have been written to recently, with the most recent ones on top.

  • Thanks a lot for those details. I tried to check the kernal version, seems like the lastest one. And then I tried to reboot and see if there are any useful log in syslog, but I only find these little things (see my edited problem description). seems like the reboot process even not go through to the point where logs can be written to the system. – kingshark Sep 15 '18 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.