0

i have installed SSH on my Linux computer. I have accessed the computer from a device that is connected to the same Wi-Fi network and it functions very well. But the problem I face is that when I try to connect externally to the Linux computer server via SSH it goes to say connection timed out. My firewall is allowing port 22 but it is still not connecting.

  • 1
    Tell us more about your setup. Is the server behind a router? Do you use NAT? Did you set up port forwarding to the server on the router? – emk2203 Sep 13 '18 at 10:55
  • i have used geth. my server is being hosted via my linux machine, while being connected to my wifi router. i have not set up port forwarding as it is very complicated. it asks for which device and what port and the ip address too. i cannot configure this as i have not used the hub manager before. i am on a bt hub 6. – namz.5659 Sep 13 '18 at 13:08
  • You MUST enable port forwarding for ssh to your server to work. – emk2203 Sep 14 '18 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.