I have no idea why this just started tonight, but I was playing a linux game in steam and noticed I couldn't view discussions or anything as the sidescroll bar just keeps popping up and down the page. I can't even grab it and control it. So I got out of steam and noticed same thing happening in Firefox. So I rebooted and same thing. I tried researching but most of the time I can't read entire pages as it keeps shifting me back to the top and down to the bottom. I did find this link after one person said it could be graphic drivers and am trying to update via this ppa: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers. But doing so in terminal, I get all updates except a message saying "holding back" on mesa-va-drivers. I have continued to sudo apt-get update & upgrade with nothing else showing as needing updating. However, my sys tray shows updates available and going into Discover they show as needing to be installed. But it never asks for my password (a recent issue so I just keep updating in terminal) so the updates hang and I have to close out of the app manager. I am very new to this and have Ubuntu 18.04 bionic with KDE Plasma. I am on a laptop with Intel i7 6th gen 8 gb ram, nVidia gtx 965m and intel 500 graphics. I am not using the touchpad and only use my mouse which has worked perfectly until tonight.

Any help would be greatly appreciated. If I need to provide more info, please advise.

  • Turn off the mouse, and turn it back on. That should probably fix it. Also make sure that you've got the latest firmware installed in the Logitech Unifying dongle. See community.logitech.com/s/question/0D531000058b3B7CAI/…. Make sure that the dongle is plugged directly into the compter's USB port. – heynnema Sep 13 at 2:28
  • My husband thought it was a dying battery so I changed batteries and it still happens. I have now turned it off and back on and it is still erratically scrolling up and down; I will check the link for firmware update you gave; I searched for that previously, but couldn't find anything on logitech site. The link you provided has nothing involving my mouse. Not sure what else to try since the unifying usb has never been unplugged and my mouse has worked perfectly for over a month since I installed kubuntu. Even now as I type this, the screen moves up and down randomly. – myviolinsings Sep 13 at 3:10
  • The link that I provided is for the updated firmware for the Unifying dongle (that runs the mouse). – heynnema Sep 13 at 4:09
  • I only see mac & pc links even though I am in Ubuntu. Do I need to boot into Windows to do this? I have a dual boot system. Thanks. – myviolinsings Sep 13 at 15:33
  • Yes. Question... does the erratic screen behavior stop if you turn off the mouse, or remove the dongle from its USB port? – heynnema Sep 13 at 15:36
up vote 0 down vote accepted

From the comments...

Unplugging the Logitech Unifying receiver and turning off the mouse solves the problem.

Narrow it down by just plugging the Unifying receiver back in, but leaving the mouse TURNED OFF. That'll identify if the mouse itself is causing the problem.

Update:

It was the mouse, as I suspected.

  • I actually did that after last comment. I turned the mouse off, put receiver back in and have been using the logitech 750 keyboard and my touchpad (which I hate) and no scrolling issues. So that means it's the mouse itself. I am going to try a different logitech mouse; have one at the home pc I could swap out. Will give it a bit and report back. Thanks. – myviolinsings Sep 14 at 22:19

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.