1

I am facing the following while trying to install edb:

sudo apt install edb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libargtable2-0 libass5 libavcodec-ffmpeg56 libavdevice-ffmpeg56
  libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
  libavutil-ffmpeg54 libbluray1 libboost-random1.58.0 libboost-regex1.58.0
  libboost-thread1.58.0 libcryptopp-dev libethereum libfdk-aac0 libjsoncpp1
  libjsonrpccpp-client0 libjsonrpccpp-common0 libjsonrpccpp-server0
  libleveldb1v5 libmicrohttpd10 libmicrohttpd12 libnvidia-common-396
  libopencv-core2.4v5 libopencv-imgproc2.4v5 libopenjpeg5 libpostproc-ffmpeg53
  libschroedinger-1.0-0 libsdl-ttf2.0-0 libswresample-ffmpeg1
  libswscale-ffmpeg3 libtbb2 libva1 libx264-148 libx265-79 miniupnpc
  php7.1-common
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  emacs emacs25 emacs25-bin-common emacs25-common emacs25-el liblockfile-bin
  liblockfile1 libm17n-0 libotf0 m17n-db
Suggested packages:
  emacs25-common-non-dfsg ncurses-term m17n-docs
The following NEW packages will be installed:
  edb emacs emacs25 emacs25-bin-common emacs25-common emacs25-el
  liblockfile-bin liblockfile1 libm17n-0 libotf0 m17n-db
0 upgraded, 11 newly installed, 0 to remove and 3 not upgraded.
Need to get 34,2 MB of archives.
After this operation, 113 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacs25-common all 25.2+1-6 [13,1 MB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/main amd64 liblockfile-bin amd64 1.14-1.1 [11,9 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 liblockfile1 amd64 1.14-1.1 [6.804 B]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacs25-bin-common amd64 25.2+1-6 [127 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 libotf0 amd64 0.9.13-3build1 [44,6 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/main amd64 m17n-db all 1.7.0-2 [1.239 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main amd64 libm17n-0 amd64 1.7.0-3build1 [243 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacs25 amd64 25.2+1-6 [3.468 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacs all 47.0 [1.748 B]
Get:10 http://archive.ubuntu.com/ubuntu bionic/universe amd64 edb all 1.31-3 [360 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacs25-el all 25.2+1-6 [15,6 MB]
Fetched 34,2 MB in 6s (5.998 kB/s)      
Selecting previously unselected package emacs25-common.
(Reading database ... 347336 files and directories currently installed.)
Preparing to unpack .../00-emacs25-common_25.2+1-6_all.deb ...
Unpacking emacs25-common (25.2+1-6) ...
Selecting previously unselected package liblockfile-bin.
Preparing to unpack .../01-liblockfile-bin_1.14-1.1_amd64.deb ...
Unpacking liblockfile-bin (1.14-1.1) ...
Selecting previously unselected package liblockfile1:amd64.
Preparing to unpack .../02-liblockfile1_1.14-1.1_amd64.deb ...
Unpacking liblockfile1:amd64 (1.14-1.1) ...
Selecting previously unselected package emacs25-bin-common.
Preparing to unpack .../03-emacs25-bin-common_25.2+1-6_amd64.deb ...
Unpacking emacs25-bin-common (25.2+1-6) ...
Selecting previously unselected package libotf0:amd64.
Preparing to unpack .../04-libotf0_0.9.13-3build1_amd64.deb ...
Unpacking libotf0:amd64 (0.9.13-3build1) ...
Selecting previously unselected package m17n-db.
Preparing to unpack .../05-m17n-db_1.7.0-2_all.deb ...
Unpacking m17n-db (1.7.0-2) ...
Selecting previously unselected package libm17n-0:amd64.
Preparing to unpack .../06-libm17n-0_1.7.0-3build1_amd64.deb ...
Unpacking libm17n-0:amd64 (1.7.0-3build1) ...
Selecting previously unselected package emacs25.
Preparing to unpack .../07-emacs25_25.2+1-6_amd64.deb ...
Unpacking emacs25 (25.2+1-6) ...
Selecting previously unselected package emacs.
Preparing to unpack .../08-emacs_47.0_all.deb ...
Unpacking emacs (47.0) ...
Selecting previously unselected package edb.
Preparing to unpack .../09-edb_1.31-3_all.deb ...
Unpacking edb (1.31-3) ...
Selecting previously unselected package emacs25-el.
Preparing to unpack .../10-emacs25-el_25.2+1-6_all.deb ...
Unpacking emacs25-el (25.2+1-6) ...
Setting up liblockfile-bin (1.14-1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Setting up libotf0:amd64 (0.9.13-3build1) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up liblockfile1:amd64 (1.14-1.1) ...
Setting up m17n-db (1.7.0-2) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up emacs25-common (25.2+1-6) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libm17n-0:amd64 (1.7.0-3build1) ...
Processing triggers for man-db (2.8.3-2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up emacs25-bin-common (25.2+1-6) ...
update-alternatives: using /usr/bin/ctags.emacs25 to provide /usr/bin/ctags (ctags) in auto mode
update-alternatives: using /usr/bin/ebrowse.emacs25 to provide /usr/bin/ebrowse (ebrowse) in auto mode
update-alternatives: using /usr/bin/emacsclient.emacs25 to provide /usr/bin/emacsclient (emacsclient) in auto mode
update-alternatives: using /usr/bin/etags.emacs25 to provide /usr/bin/etags (etags) in auto mode
Setting up emacs25-el (25.2+1-6) ...
Setting up emacs25 (25.2+1-6) ...
update-alternatives: using /usr/bin/emacs25-x to provide /usr/bin/emacs (emacs) in auto mode
Install edb for emacs25
install/edb: Handling install of emacsen flavor emacs25
install/edb: Byte-Compiling in dir /usr/share/emacs/site-lisp/edb/ ...
No such keyword: :indent
ERROR: install script from edb package failed
dpkg: error processing package emacs25 (--configure):
 installed emacs25 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of emacs:
 emacs depends on emacs25 | emacs25-lucid | emacs25-nox; however:
  Package emacs25 is not configured yet.
  Package emacs25-lucid is not installed.
  Package emacs25-nox is not installed.

dpkg: error processing package emacs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of edb:
 edb depends on emacs | emacs24 | emacs-snapshot; however:
  Package emacs is not configured yet.
  Package emacs24 is not installed.
  Package emacs-snapshot is not installed.

dpkg: error processing package edb (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    Errors were encountered while processing:
 emacs25
 emacs
 edb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Following up another on hold question (Unable to install edb Ubuntu 17.10):

sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libargtable2-0 libass5 libavcodec-ffmpeg56 libavdevice-ffmpeg56
  libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
  libavutil-ffmpeg54 libbluray1 libboost-random1.58.0 libboost-regex1.58.0
  libboost-thread1.58.0 libcryptopp-dev libethereum libfdk-aac0 libjsoncpp1
  libjsonrpccpp-client0 libjsonrpccpp-common0 libjsonrpccpp-server0
  libleveldb1v5 libmicrohttpd10 libmicrohttpd12 libnvidia-common-396
  libopencv-core2.4v5 libopencv-imgproc2.4v5 libopenjpeg5 libpostproc-ffmpeg53
  libschroedinger-1.0-0 libsdl-ttf2.0-0 libswresample-ffmpeg1
  libswscale-ffmpeg3 libtbb2 libva1 libx264-148 libx265-79 miniupnpc
  php7.1-common
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up emacs25 (25.2+1-6) ...
Install edb for emacs25
install/edb: Handling install of emacsen flavor emacs25
install/edb: Byte-Compiling in dir /usr/share/emacs/site-lisp/edb/ ...
No such keyword: :indent
ERROR: install script from edb package failed
dpkg: error processing package emacs25 (--configure):
 installed emacs25 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of emacs:
 emacs depends on emacs25 | emacs25-lucid | emacs25-nox; however:
  Package emacs25 is not configured yet.
  Package emacs25-lucid is not installed.
  Package emacs25-nox is not installed.

dpkg: error processing package emacs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of edb:
 edb depends on emacs | emacs24 | emacs-snapshot; however:
  Package emacs is not configured yet.
  Package emacs24 is not installed.
  Package emacs-snapshot is not installed.

dpkg: error processing package edb (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    Errors were encountered while processing:
 emacs25
 emacs
 edb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    I can reproduce you issue on clean Ubuntu 18.04 LTS without PPAs and any third-party repositories. So I reported bug 1792211 to Launchpad. – N0rbert Sep 12 '18 at 19:39
1

I was confused:

sudo apt install edb-debugger
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  emacs emacs25 emacs25-bin-common emacs25-common emacs25-el libargtable2-0
  libass5 libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5
  libavformat-ffmpeg56 libavresample-ffmpeg2 libavutil-ffmpeg54 libbluray1
  libboost-random1.58.0 libboost-regex1.58.0 libboost-thread1.58.0
  libcryptopp-dev libethereum libfdk-aac0 libjsoncpp1 libjsonrpccpp-client0
  libjsonrpccpp-common0 libjsonrpccpp-server0 libleveldb1v5 liblockfile-bin
  liblockfile1 libm17n-0 libmicrohttpd10 libmicrohttpd12 libnvidia-common-396
  libopencv-core2.4v5 libopencv-imgproc2.4v5 libopenjpeg5 libotf0
  libpostproc-ffmpeg53 libschroedinger-1.0-0 libsdl-ttf2.0-0
  libswresample-ffmpeg1 libswscale-ffmpeg3 libtbb2 libva1 libx264-148
  libx265-79 m17n-db miniupnpc php7.1-common
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  edb-debugger-plugins libcapstone3 libcdt5 libcgraph6 libgts-0.7-5 libgts-bin
  libgvc6 libpathplan4 libqt5concurrent5 libqt5xmlpatterns5
The following NEW packages will be installed:
  edb-debugger edb-debugger-plugins libcapstone3 libcdt5 libcgraph6
  libgts-0.7-5 libgts-bin libgvc6 libpathplan4 libqt5concurrent5
  libqt5xmlpatterns5
0 upgraded, 11 newly installed, 0 to remove and 3 not upgraded.
Need to get 3.105 kB of archives.
After this operation, 13,1 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libcapstone3 amd64 3.0.4-5 [434 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libcdt5 amd64 2.40.1-2 [19,6 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libcgraph6 amd64 2.40.1-2 [40,8 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libgts-0.7-5 amd64 0.7.6+darcs121130-4 [150 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libpathplan4 amd64 2.40.1-2 [22,6 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libgvc6 amd64 2.40.1-2 [601 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libqt5xmlpatterns5 amd64 5.9.5-0ubuntu1 [916 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic/main amd64 libqt5concurrent5 amd64 5.9.5+dfsg-0ubuntu1 [29,8 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic/universe amd64 edb-debugger-plugins amd64 0.9.21-3 [444 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic/universe amd64 edb-debugger amd64 0.9.21-3 [406 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libgts-bin amd64 0.7.6+darcs121130-4 [41,3 kB]
Fetched 3.105 kB in 1s (3.363 kB/s)    
Selecting previously unselected package libcapstone3:amd64.
(Reading database ... 352020 files and directories currently installed.)
Preparing to unpack .../00-libcapstone3_3.0.4-5_amd64.deb ...
Unpacking libcapstone3:amd64 (3.0.4-5) ...
Selecting previously unselected package libcdt5.
Preparing to unpack .../01-libcdt5_2.40.1-2_amd64.deb ...
Unpacking libcdt5 (2.40.1-2) ...
Selecting previously unselected package libcgraph6.
Preparing to unpack .../02-libcgraph6_2.40.1-2_amd64.deb ...
Unpacking libcgraph6 (2.40.1-2) ...
Selecting previously unselected package libgts-0.7-5:amd64.
Preparing to unpack .../03-libgts-0.7-5_0.7.6+darcs121130-4_amd64.deb ...
Unpacking libgts-0.7-5:amd64 (0.7.6+darcs121130-4) ...
Selecting previously unselected package libpathplan4.
Preparing to unpack .../04-libpathplan4_2.40.1-2_amd64.deb ...
Unpacking libpathplan4 (2.40.1-2) ...
Selecting previously unselected package libgvc6.
Preparing to unpack .../05-libgvc6_2.40.1-2_amd64.deb ...
Unpacking libgvc6 (2.40.1-2) ...
Selecting previously unselected package libqt5xmlpatterns5:amd64.
Preparing to unpack .../06-libqt5xmlpatterns5_5.9.5-0ubuntu1_amd64.deb ...
Unpacking libqt5xmlpatterns5:amd64 (5.9.5-0ubuntu1) ...
Selecting previously unselected package libqt5concurrent5:amd64.
Preparing to unpack .../07-libqt5concurrent5_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking libqt5concurrent5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package edb-debugger-plugins:amd64.
Preparing to unpack .../08-edb-debugger-plugins_0.9.21-3_amd64.deb ...
Unpacking edb-debugger-plugins:amd64 (0.9.21-3) ...
Selecting previously unselected package edb-debugger.
Preparing to unpack .../09-edb-debugger_0.9.21-3_amd64.deb ...
Unpacking edb-debugger (0.9.21-3) ...
Selecting previously unselected package libgts-bin.
Preparing to unpack .../10-libgts-bin_0.7.6+darcs121130-4_amd64.deb ...
Unpacking libgts-bin (0.7.6+darcs121130-4) ...
Setting up libgts-0.7-5:amd64 (0.7.6+darcs121130-4) ...
Setting up libpathplan4 (2.40.1-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up libqt5xmlpatterns5:amd64 (5.9.5-0ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libgts-bin (0.7.6+darcs121130-4) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Setting up libcapstone3:amd64 (3.0.4-5) ...
Setting up libqt5concurrent5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up libcdt5 (2.40.1-2) ...
Setting up libcgraph6 (2.40.1-2) ...
Setting up edb-debugger-plugins:amd64 (0.9.21-3) ...
Setting up libgvc6 (2.40.1-2) ...
Setting up edb-debugger (0.9.21-3) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

edb and edb-debugger are not the same.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.