3

I am using Kubuntu 18.04.1 and I am unable to find where to set options for screen locking or screen saver.

Display and Monitor menu

Version of KDE framework:

About Kubuntu

5 Answers 5

1

Look at System SettingsDesktop Behavior.

Screen Locking

Re. a screensaver, that's not included by default because modern screens aren't affected.

But, if you're interested, look at Where are the screensavers.

1

I have Kubuntu 18.04 - with nVidia drivers..

The problem is that there are TWO places where this is set.

In the setup tool, there is Workspace/Desktop Behavior/Screen Locking - where I can say "Lock screen automatically after:" then enter a time in minutes.

This does not work worth a damn. I can lock the screen manually - but not have it happen automatically.

However, hidden away under Hardware/Power Management/Energy Saving - there is "Screen Energy Saving" and "Switch off after"...which DOES work.

It's not quite the same thing though because it doesn't lock the screen - and it literally turns the video off rather than displaying a blank screen (or whatever) but for me, it's "good enough".

Screen savers no longer exist without you installing a bunch of extra stuff. So your lock screen (if you can get it to work) won't be any of the cool animations we used to have.

1
  • sad state of affairs
    – lurscher
    Commented Sep 20, 2018 at 14:50
1

There are two settings. The screen locking and screen switch off.

If I want both locking and switch off, it is necessary to switch off the screen after screen locking. Otherwise the lock screen will wake up the screen, which leads to burn-in of the screen (more accurately, image persistence). What works for me is:

  • Desktop BehaviorScreen LockingActivationLock screen automatically after10 mins
  • Power managementEnergy SavingScreen Energy SavingSwitch off after15 mins

This specific behavior may be influenced by my proprietary NVIDIA driver.

0

Actually you can find the screen locking on the Energy section of System Preferences.There you could choose the locking behavior and many more.

I hope you know that Ctrl+Alt+L locks the display window.

The screen saver option was answered by DK Bose.

0

In kUbuntu 20.04 look at System SettingsScreen Locking.

There is no System SettingsDesktop Behavior in my system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .