0

I' m using a Mediacom W700 tablet (is like a SurfTab wintron 7.0 ST70416-6) with Lubuntu 18.04 (i also installed Ubuntu-dekstop but it has only 1 GB of ram).
How enable the speakers,microphone and camera?
Also the super (physical) button doesn' t work.
In hardinfo i see: Audio: bytcr-rt5651 - bytcr-rt5651.
So i used:

dmesg | grep bytcr
[   39.559314] bytcr_rt5651 bytcr_rt5651: quirk DMIC_MAP enabled
[   39.559319] bytcr_rt5651 bytcr_rt5651: quirk DMIC enabled
[   39.559322] bytcr_rt5651 bytcr_rt5651: quirk MCLK_EN enabled
[   39.581339] bytcr_rt5651 bytcr_rt5651: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
[   39.581426] bytcr_rt5651 bytcr_rt5651: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok
[   39.581557] bytcr_rt5651 bytcr_rt5651: rt5651-aif1 <-> ssp2-port mapping ok
[   39.581652] bytcr_rt5651 bytcr_rt5651: ASoC: no DMI vendor name!
[   39.583777] input: bytcr-rt5651 Headset as /devices/platform/80860F28:00/bytcr_rt5651/sound/card1/input6

I found this project on github, it seems perfect, it states:

To enable UCM on RT5651 platforms,

  1. copy directory to UCM location sudo cp -rf ../bytcr-rt5651 /usr/share/alsa/ucm

  2. update asound.state sudo cp asound.state /var/lib/alsa

UCM files should be detected and use with Pulseaudio 4.0 and above

I followed the step and i have pulseaudio above of 4.0.
If i run sudo sh asound.state in /var/lib/alsa i get:

asound.state: 1: asound.state: state.bytcrrt5651: not found
asound.state: 2: asound.state: control.1: not found
asound.state: 3: asound.state: iface: not found
asound.state: 4: asound.state: name: not found
asound.state: 5: asound.state: value: not found
asound.state: 6: asound.state: comment: not found
asound.state: 7: asound.state: access: not found
BOOLEAN: not found
asound.state: 9: asound.state: count: not found
asound.state: 10: asound.state: Syntax error: "}" unexpected

Other commands that may be useful:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytcrrt5651 [bytcr-rt5651], device 0: 1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytcrrt5651 [bytcr-rt5651], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Not sound at all from the speakers and the headphones.

  • Maybe this post about audio rendering in ubuntu may help. – oscar1919 Sep 12 '18 at 12:27
  • @oscar1919 good to know but is some hardware/driver problem. – Scorpion Sep 14 '18 at 9:14
0

In this project http://linuxiumcomau.blogspot.com/2017/06/customizing-ubuntu-isos-documentation.html you can find 6 files (4 scripts and 2 .deb) that are made for intel atom devices.
This files are for the bluetooth, wi-fi and audio. But you need the new kernel.
Wi-fi was already fine.

Kernel 4.18.15 audio working, pretty low max (speakers) volume, maybe is so by default.

Kernel 4.19 (not stable) also the bluetooth but i did not test it, now i have the stable kernel.

  • and the camera? – Scorpion Oct 31 '18 at 11:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.