I only recently started using Ubuntu a few days ago (11.10), so sorry if I fail to mention specific things that may help someone answer me. That's probably why this is going to come out wordy.

I have a Dell Inspiron 1501 laptop, and I've been looking around to see if there was a way for me to install the graphics driver (ATI IGP Xpress 1150) so I could use Unity 3D. I wasn't sure if I was actually already running it, but I wanted to see if I could enable my graphics driver anyway. As far as I knew, doing that would make things run smoother. I followed the instructions someone placed here: Jockey not detecting my ATI IGP Xpress 1150 and it installed...something.

Things were still working fine after I did that, so I went into Compiz to see what kind of things I could tweek. I don't recall what the last thing I tried to enable was (it might have been Desktop Cube) but right after that, all the windows I had open lost their bars (forget the word for it, but you know the bar that has the minimize, restore and close buttons on it), the launcher disappeared, even the taskbar. So I restarted my laptop, and now the workspace switcher, instead of a square that showed each workspace and allowed me to move up and down as well as left and right, is replaced with a straight rectangle that only allows me to move left and right (still with four workspaces). I had only seen that before when I ran Unity 2D as a test, but I know I'm not using 2D, and I'd like to go back.

For what it's worth, I don't think it really had anything to do with me attempting to install the driver. As things are now, things are moving less laggy on my screen. But I really liked the way the workspace switcher had worked up until now. I think it was something in Compiz that I accidentally disabled for something else, but I'm not sure where to begin to rectify that.

  • 1
    Please Put the solution as the answer, don't edit the question to add it. – Uri Herrera Feb 25 '12 at 1:16

Answer edited out from the question

So I was just about ready to do something drastic when I figured out how to both uninstall fglrx and reset whatever tweaks I had made in Compiz, everything seems to be working fine now.

  • 1
    good catch - dont forget to flag so that we can upvote community-wikis. thanks. – fossfreedom Mar 10 '12 at 10:26
  • I post them in the Ubuntu regulators chat room, just to ensure that it is not missed. :) – jokerdino Mar 10 '12 at 10:30

the reason it fails is because Unity is a Compiz plugin and you have deactivated that plugin. The reason you did this is because Unity depends on the "LargeDesktop" feature which is a feature provided by "Wall" and "Cube". Great, you may think, I can use either. Well the problem is that when you switch from wall to cube you have to remove wall, then activate cube. Removing wall removes the largedesktop feature momentarily, and in that fraction of a second when you have no largedesktop providing pluging the unity plugin gets unloaded. You need to turn this back on by running ccsm in your unity2d session and checking the box on the unity plugin. You can then go back to 3d. In 12.04 I patched the unity plugin so the daft and pointless dependency has been removed so people don't break their desktops.

  • I see, thanks. Just edited my response to say that my problem is now solved. – Michael Feb 25 '12 at 1:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.