1

Since upgrading from Ubuntu 16.04 to 18.04 my Epson Workforce 2760 printer will not scan documents. I have tried everything I can find related to this problem with zero success. I have tried installing backends and setting permissions. There are others who are having this problem but perhaps not enough to get to a level that attracts the attention of someone who can help. There may be a bug in the 18.04 version that causes this and hopefully either a workaround or a fix can be discovered soon.

One thing I tried was this:

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane

Still no success. Possibly the upgrade to Ubuntu 18.04 broke something within the Sane setup. I don't know how to "provide some more details, like the output for lsusb to prove the scanner is actually attached and recognized." Found this: https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012

Here is output of "sudo sane-find-scanner" : # sane-find-scanner will now attempt to detect your scanner. If the # result is different from what you expected, first make sure your # scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error could not fetch string descriptor: Pipe error found USB scanner (vendor=0x04b8 [EPSON], product=0x111c [EPSON WF-2760 Series]) at libusb:005:002 # Your USB scanner was (probably) detected. It may or may not be supported by # SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports # can't be detected by this program.

  • Please edit your question to include what you have tied so far in relation to software solutions. – Graham Sep 11 '18 at 19:59
  • You need to provide some more detials, like the output for lsusb to prove the scanner is actually attached and recognized. – EnzoR Sep 12 '18 at 15:52
1

Accordingly to the SANE project "supported devices" list, your scanner isn't supported.

  • 1
    Is there anything I can do to make my printer/scanner functional in Ubuntu 18.04. It worked fine in Ubuntu 16.04. – lab7755 Sep 13 '18 at 14:12
  • @lab7755 I think that 16.04 was able to detect and use that scanner because some "trick" has been applied. I would also try to reinstall some SANE libraries. Try sudo apt-get -y --reinstall install libsane libsane-extras and then again sudo sane-find-scanner and sudo scanimage -L. Use sudo first to avoid possible issues with device permissions, then without it. – EnzoR Sep 13 '18 at 18:24
  • I appreciate your help but still I cannot use my scanner. – lab7755 Sep 16 '18 at 14:23
  • The list of supported devices is not complete. I got my WF-7710 working across WiFi. My guess is, all Epson WorkForce models work through the non-free network-scanning driver-plugin supplied with Epson's Image Scan v3 software. Some additional, manual setup is necessary. See askubuntu.com/questions/895002: You have to set the hostname or IP address in /etc/imagescan/imagescan.conf. (The autodiscovery, as in /etc/sane.d/epson2.conf, is not doing it for the driver-plugin.) – Peterino May 19 at 21:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.