1

You might want to run apt-get -f install to correct these. The following packages have unmet dependencies.

mysql-workbench-community : Depends: libcairo2 (>= 1.15.8) but 1.14.6-1 is installed
                             Depends: libglibmm-2.4-1v5 (>= 2.54.0) but 2.46.3-1 is installed
                             Depends: libgtk-3-0 (>= 3.21.5) but 3.18.9-1ubuntu3.3 is installed
                             Depends: libgtkmm-3.0-1v5 (>= 3.22.0) but 3.18.0-1 is installed
                             Depends: libpangomm-1.4-1v5 (>= 2.40.0) but 2.38.1-1 is installed
                             Depends: libpcrecpp0v5 (>= 7.7) but it is not installed
                             Depends: libpng16-16 (>= 1.6.2-1) but it is not installed
                             Depends: libsigc++-2.0-0v5 (>= 2.8.0) but 2.6.2-1 is installed
                             Depends: libssl1.1 (>= 1.1.0) but it is not installable
                             Depends: libstdc++6 (>= 7) but 5.4.0-6ubuntu1~16.04.10 is installed
                             Depends: libvsqlitepp3v5 (>= 0.3.13) but it is not installed
                             Depends: libzip4 (>= 0.10) but it is not installed
E: Unmet dependencies. Try using -f.

marked as duplicate by N0rbert, Fabby, Lucio, karel, guiverc Sep 13 '18 at 9:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Tried apt-get -f install still not working – Rupeshpanneerselvam Sep 11 '18 at 12:00
  • 1
    What is the initial command you run when getting this error? – pLumo Sep 11 '18 at 12:22
  • Looks like you have introduced a version conflict by trying to install a wrong-version package. The package's dependencies are incompatible with the rest of your system (that's what all those 'Depends:' lines are trying to tell you - read them!) Rather like using a bicycle tire of wrong diameter, simply uninstall the wrong-version package to fix the problem. – user535733 Sep 11 '18 at 12:33
  • Please add output of apt-cache policy mysql-workbench-community to the question. There is no such official Ubuntu package in the repos. – N0rbert Sep 11 '18 at 20:12
  • @Rupeshpanneerselvam What version of Ubuntu you are using? – edwinksl Oct 19 '18 at 2:46