1

I’ve installed vscode and vlc via snap commands and each time I launch them from the terminal, I got this message:

snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Any help please!

1

These steps help me resolve permanently my problem:

  • Remove snapd: sudo apt purge snapd snap-confine

  • Update: sudo apt update

  • Reinstall it: sudo apt install snapd

  • Check apparmor's status: systemctl status apparmor

  • If status inactive, then activate it: systemctl start apparmor

  • Now install any app you want via snap commands line

Remember, you must check and activate apparmor before installing any app.

  • It shall be good thing if someone can show us how to activate permanently apparmor – Goodness Sep 11 '18 at 11:20
0

After following the instructions in Goodness's answer I needed to reinstall my snap apps. Obviously I don't want to do that repeatedly.

The main snap app I use is PyCharm and I found some advice about using the classic option when installing to a more relaxed policy. For example:

sudo snap install pycharm-community --classic

It remains to be seen whether that solves the problem permanently.

The reason this has happened is due to this bug in snapd.

  • Just to make it a bit more explicit: If apparmor is not running , start it. (see Goodness' answer). Then install the app of your choice with the classic mode. No need to reinstall snap. At least this worked for me. – rwitzel Jan 15 at 8:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.