8

I am using Ubuntu 18.04 LTS. Whenever I try to copy/paste content from/to my Android phone's memory card, I get this error:

libmtp Error : Could not send object info.

Please help me to solve this.

6 Answers 6

8

I'm not sure if you have solved this but I came across the same issues today. I was trying to copy music to my Android's phone SD card and I got this error when the file name of the song, not the tag, had 'illegal' symbols in it. I removed the apostrophe and the file copied over. 05 Goodbye 70's.flac change to 05 Goodbye 70s.flac

Hope this helps.

1
  • Please include how did you remove the apostrophe. May 1, 2019 at 19:53
3

Agree with Geoffrey. I bumped into the same problem with the filename. For me the 'illegal character was the colon ':' character. The filename which caused the problem was 'Disc 1 - 11 - The Narcotic Suite: 3 Kilos.ogg', renaming the file to 'Disc 1 - 11 - The Narcotic Suite 3 Kilos.ogg' ensured that the file could be copied.

I used the 'Files' app to rename the file, right-click on the filename and choose the 'rename' option.

1

Other than the filename issue mentioned above, another possible reason is that the file to be copied is too big for the MTP device. For example, I get this error when I try to copy a 5GB movie to a SD card, which seems not accepting such large file.

1

Try compressing it and then copy-pasting it. It worked when I tried copying ~11 GB zip file.

0
1

I solved this problem by removing all the 0000 embedded file .config files from the Android mobile.

1

I solved this problem by using another USB cable. Copy files from Ubuntu 18.04 to Android 14 device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .