7

After upgrading from Ubuntu 16.04 to 18.04, phpmyadmin shows the below message:

OpenSSL error: error:0906D06C:PEM routines:PEM_read_bio:no start line

The system was fine before upgrading.

5
  • 1
    I'm having the same error. I have the same config in Cent OS 7 and it works. But with Ubuntu 16.04 doesn't. – david.perez Nov 26 '18 at 11:33
  • Which is giving you this error? PHPMyAdmin, or Apache? Typically this indicates that the configuration for the SSL has 'broken' in terms of how PMA connects to MySQL, and you would have to reconfigure the SSL on the backend. – Thomas Ward Mar 4 '19 at 14:50
  • 1
    PHPMyAdmin 4:4.6.6-5 running on Ubuntu 18.04.2 LTS I get also this error: OpenSSL error: error:04091077:rsa routines:int_rsa_verify:wrong signature length – koni_raid Mar 4 '19 at 16:03
  • 1
    check if the file format of your SSL certs is correct. Or maybe you have some copy/paste errors or even things like "^M" in there. What this error says is, that openssl cannot read your PEM files or cannot find the "-----BEGIN CERTIFICATE-----" – Robert Riedl Mar 7 '19 at 17:07
  • I stand by my comment from 2019: openssl cannot read your PEM files – Robert Riedl Mar 16 '20 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.