0

I created a Desktop URL entry that worked once but when I tried to create a 2nd URL link using gedit on the desktop it fails.
I can't look at my original classic hits icon that works with gimp. My failing Country Roads.desktop reads as

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Name= Link to Country Roads
Type=Link
Exec=http://tune-in.com/radio/Country-Roads-s224628/

[Internet Shortcut]
URL=http://tune-in.com/radio/Country-Roads-s224628/
Icon=gnome-panel-launcher
1

Your .desktop launcher doesn't look right, change it to

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Name= Link to Country Roads
Type=Link
URL=http://tune-in.com/radio/Country-Roads-s224628/
Icon=gnome-panel-launcher
| improve this answer | |
  • When I responded I forgot to type the encoding line after Desktop Entry but that was in my entry. But I did removed the line [Internet Shortcut] but it still doesn't work. – RobMit Sep 14 '18 at 2:28
  • @RobMit It's not just about removing the [Internet Shortcut] line, the Exec=http://tune-in.com/radio/Country-Roads-s224628/ line is absolutely wrong. Please just copy/paste from my answer. – pomsky Sep 14 '18 at 4:43
  • I am a Windows person trying to switch some of my systems over to Linux and I am currently working with the Xtra-pc 64 flash drive that uses Ubuntu. I have been adding additional applications and fixing the applications that don't work right, I pasted your text into Notepad and moved it over to my Xtra-pc Desktop and it works now. Thanks. Once the desktop Icons work I can no longer edit them in gedit all I can do then is look at the properties. Why is that? – RobMit Sep 19 '18 at 23:15
  • @RobMit In that case consider "accepting" the answer (by clicking on the tick mark (✓) next to it) so that others may more easily find it in the future. – pomsky Sep 20 '18 at 5:14
  • @RobMit Once you have fixed the file, it became a proper launcher. Nautilus (file manager app which also provides the desktop icons) is unaware to the fact that gedit can also handle launchers, that's why you don't see a "open with gedit" option. To open and edit the launcher with gedit, first launch gedit, the hit <Ctrl>+<O> and select the launcher (note that it would look like Country Roads.desktop in the "open file" dialogue, won't show up as Link to Country Roads). – pomsky Sep 20 '18 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.