2

This occurs with both the 4.15 stock Ubuntu kernel and the 4.18.5 kernel I updated to in order to get the wifi interface to work. (Updated using uuku)

Things I have tried:

  • Installing latest nvidia drivers with ubuntu-drivers autoinstall
    • Doing this blacklists the nouveau driver which is the source of many posts on the topic.
    • Disabling the nvidia-fallback.service causes the system to black screen on login so I re-enabled that service.

I can't find anything suspicious looking in any of the logs.

[Update 09/19/2018: I ran through the instructions in https://wiki.ubuntu.com/DebuggingKernelSuspend and interestingly the forced suspend command it contains does NOT trigger the crashing behavior! I can resume just fine when I do that - although I had to substitute systemctl suspend for the pm_suspend command since that's no longer available in 18.04 I think? Does closing the lid trigger a different suspend mechanism than systemctl suspend?]

2
1

In rare cases when resuming after suspend NVMe M.2 SSD's are not powered up again if they are Gen 3.0 x 4 bus lanes. Although this was promised to be fixed in an older kernel version it has not appeared yet: Cannot suspend with NVMe M.2 SSD

If you have such an SSD try the following:

Edit /etc/default/grub with sudo powers and find the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet kaslr acpiphp.disable=1 pcie_aspm=off nloglevel=3 udev.log-priority=3"

Your options will be different but add the option acpihp.disable=1 between the double quotes.

Save the file and run sudo update-grub.

Reboot and then suspend and resume will work.

4
  • Hrrm. Thanks I haven't had luck with this yet. – Christopher Patti Sep 9 '18 at 23:56
  • I edited my /etc/default/grub like so: GRUB_CMDLINE_LINUX_DEFAULT="quiet acpiphp.disable=1 splash" – Christopher Patti Sep 9 '18 at 23:56
  • 1
    It's not the problem but it's tradition to put new variables after quiet splash so it would look like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpiphp.disable=1". As I mentioned previously I had problems suspending in 18.04 which is one of the reasons I'm using 16.04 instead. It could very well be you have another problems besides/instead of the NVMe SSD. – WinEunuuchs2Unix Sep 10 '18 at 0:01
  • 1
    @ChristopherPatti Sorry just noticed the command sudo update-grub was missing. I added it to the answer. – WinEunuuchs2Unix Sep 10 '18 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.