2

My computer's wireless interface, and the wifi system tray icon, seem to be disappearing after going into suspend. I was wondering if anyone could take a look at these logs and tell me what's going wrong and how to fix it.

System information: release: 18.04 (bionic) kernel: 4.18.6-041806-generic Model name: Atom x5-Z8350 Network Controller: Intel Corporation Wireless 3165 (rev 91)

--------BEFORE SUSPEND--------

--------------network information-------------------
   *-network
        description: Wireless interface
        product: Wireless 3165
        vendor: Intel Corporation
        physical id: 0
        bus info: pci@0000:01:00.0
        logical name: wlp1s0
        version: 91
        serial: 5c:5f:67:11:6f:02
        width: 64 bits
        clock: 33MHz
        capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
        configuration: broadcast=yes driver=iwlwifi driverversion=4.18.6-041806-generic firmware=29.1044073957.0 ip=192.168.0.249 latency=0 link=yes multicast=yes wireless=IEEE 802.11
        resources: irq:170 memory:91800000-91801fff
 -------------interfaces-------------------------
 lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
         inet 127.0.0.1  netmask 255.0.0.0
         inet6 ::1  prefixlen 128  scopeid 0x10<host>
         loop  txqueuelen 1000  (Local Loopback)
         RX packets 158  bytes 11300 (11.3 KB)
         RX errors 0  dropped 0  overruns 0  frame 0
         TX packets 158  bytes 11300 (11.3 KB)
         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 wlp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
         inet 192.168.0.249  netmask 255.255.0.0  broadcast 192.168.255.255
         inet6 fe80::b85b:f73c:22eb:4c19  prefixlen 64  scopeid 0x20<link>
         ether 5c:5f:67:11:6f:02  txqueuelen 1000  (Ethernet)
         RX packets 1414  bytes 1591823 (1.5 MB)
         RX errors 0  dropped 0  overruns 0  frame 0
         TX packets 483  bytes 70469 (70.4 KB)
         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 ----------modules loaded-----------------
 iwlmvm                368640  0
 mac80211              794624  1 iwlmvm
 iwlwifi               294912  1 iwlmvm
 cfg80211              663552  3 iwlmvm,iwlwifi,mac80211
 -----wireless interfaces on the PCI bus-------------
 01:00.0 Network controller: Intel Corporation Wireless 3165 (rev 91)
 ---------------dmesg iwlwifi messages------------
 [    8.010596] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
 [    8.058278] iwlwifi 0000:01:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
 [    8.164682] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
 [    8.185604] iwlwifi 0000:01:00.0: base HW address: 5c:5f:67:11:6f:02
 [    8.312646] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
 [    8.725232] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
 ----------------rfkill list-----------------
 0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
 1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
 ------------------------------------------

-------AFTER SUSPEND------------

--------------network information-------------------
   *-generic DISABLED
        description: Wireless interface
        product: Illegal Vendor ID
        vendor: Illegal Vendor ID
        physical id: 0
        bus info: pci@0000:01:00.0
        logical name: wlp1s0
        version: ff
        serial: 5c:5f:67:11:6f:02
        width: 32 bits
        clock: 66MHz
        capabilities: bus_master vga_palette cap_list ethernet physical wireless
        configuration: broadcast=yes driver=iwlwifi driverversion=4.18.6-041806-generic firmware=29.1044073957.0 latency=255 link=no maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
        resources: irq:169 memory:91800000-91801fff
 -------------interfaces-------------------------
 lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
         inet 127.0.0.1  netmask 255.0.0.0
         inet6 ::1  prefixlen 128  scopeid 0x10<host>
         loop  txqueuelen 1000  (Local Loopback)
         RX packets 407  bytes 25905 (25.9 KB)
         RX errors 0  dropped 0  overruns 0  frame 0
         TX packets 407  bytes 25905 (25.9 KB)
         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 ----------modules loaded-----------------
 iwlmvm                368640  0
 mac80211              794624  1 iwlmvm
 iwlwifi               294912  1 iwlmvm
 cfg80211              663552  3 iwlmvm,iwlwifi,mac80211
 -----wireless interfaces on the PCI bus-------------
 01:00.0 Network controller: Intel Corporation Wireless 3165 (rev ff)
 ---------------dmesg iwlwifi messages------------
 [    8.287748] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
 [    8.340982] iwlwifi 0000:01:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
 [    8.471943] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
 [    8.491512] iwlwifi 0000:01:00.0: base HW address: 5c:5f:67:11:6f:02
 [    8.616728] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
 [    9.077477] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
 [   50.472453] iwlwifi 0000:01:00.0: Refused to change power state, currently in D3
 [   52.138217] WARNING: CPU: 1 PID: 869 at drivers/net/wireless/intel/iwlwifi/pcie/trans.c:2008 iwl_trans_pcie_grab_nic_access+0x1e8/0x220 [iwlwifi]
 [   52.138220] Modules linked in: ccm cmac bnep binfmt_misc nls_iso8859_1 snd_soc_sst_bytcr_rt5651 axp288_fuel_gauge axp288_adc axp20x_pek axp288_charger extcon_axp288 joydev gpio_keys intel_rapl intel_powerclamp coretemp kvm_intel kvm irqbypass punit_atom_debug crct10dif_pclmul arc4 crc32_pclmul ghash_clmulni_intel pcbc iwlmvm mac80211 aesni_intel btusb btrtl snd_intel_sst_acpi aes_x86_64 snd_intel_sst_core btbcm crypto_simd snd_soc_rt5651 snd_soc_sst_atom_hifi2_platform btintel input_leds cryptd snd_soc_acpi glue_helper bluetooth snd_soc_rl6231 snd_soc_acpi_intel_match intel_cstate iwlwifi snd_soc_core snd_compress snd_hdmi_lpe_audio ecdh_generic ac97_bus snd_pcm_dmaengine cfg80211 snd_pcm intel_xhci_usb_role_switch roles processor_thermal_device mei_txe intel_soc_dts_iosf mei snd_seq_midi lpc_ich
 [   52.138389] RIP: 0010:iwl_trans_pcie_grab_nic_access+0x1e8/0x220 [iwlwifi]
 [   52.138497]  iwl_write_prph+0x3d/0x90 [iwlwifi]
 [   52.138514]  iwl_pcie_apm_init+0x1db/0x240 [iwlwifi]
 [   52.138531]  iwl_trans_pcie_start_hw+0x52/0x1d0 [iwlwifi]
 [   52.138551]  iwl_mvm_up+0x3c/0x9c0 [iwlmvm]
 [   52.138581]  __iwl_mvm_mac_start+0x29b/0x300 [iwlmvm]
 [   52.138596]  iwl_mvm_mac_start+0x4c/0x130 [iwlmvm]
 [   52.138767]  ? iwl_write32+0x39/0x90 [iwlwifi]
 [   52.139021] iwlwifi 0000:01:00.0: iwlwifi transaction failed, dumping registers
 [   52.139030] iwlwifi 0000:01:00.0: iwlwifi device config registers:
 [   52.139374] iwlwifi 0000:01:00.0: 00000000: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
 [   52.139381] iwlwifi 0000:01:00.0: 00000020: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
 [   52.139385] iwlwifi 0000:01:00.0: iwlwifi device memory mapped registers:
 [   52.139615] iwlwifi 0000:01:00.0: 00000000: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
 [   52.139621] iwlwifi 0000:01:00.0: 00000020: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
 [   52.146445] iwlwifi 0000:01:00.0: iwlwifi parent port (0000:00:1c.0) config registers:
 [   52.146786] iwlwifi 0000:00:1c.0: 00000000: 22c88086 00100407 06040036 00810010 00000000 00000000 00010100 200000f0
 [   52.146793] iwlwifi 0000:00:1c.0: 00000020: 91809180 0001fff1 00000000 00000000 00000000 00000040 00000000 001001ff
 [   54.173212] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [   54.173259] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [   54.173265] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [   54.173269] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [   61.058766] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [   61.058811] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [   61.058820] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [   61.058827] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [   67.954978] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [   67.955023] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [   67.955031] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [   67.955037] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [   84.745455] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [   84.745501] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [   84.745507] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [   84.745511] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [   91.610538] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [   91.610587] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [   91.610593] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [   91.610597] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [  108.735183] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [  108.735232] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [  108.735244] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [  108.735251] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 [  115.619723] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
 [  115.619761] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
 [  115.619766] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
 [  115.619770] iwlwifi 0000:01:00.0: Failed to start RT ucode: -5
 ----------------rfkill list-----------------
 0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
 1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
 ------------------------------------------
0

I had this problem, though in my case I think I have a different wifi chipset than you.

In any case, this may be worth a look. My wifi card was being "soft blocked" by the kernel. You might find this answer. It's what worked for me.

  • That's what I thought too, but after suspend, used rfkill to see if I was being soft blocked, and apparently I wasn't (see bottom of second log file). The biggest difference I could see was in the output of "lshw -C network" (under the ---network---) divider, which reported that the wireless interface had been disabled. The reason for this, I think, is likely because of the mess of stuff in the log file starting with: "iwlwifi 0000:01:00.0: Refused to change power state, currently in D3". What that means, I think, might be important to understanding how to solve this problem. – 5JiggaWatts Sep 10 '18 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.