4

[I know this is duplicate but all the answers here didn't work for me.]

I am a life-long Windows user who has migrated to Ubuntu since 5 weeks.

I am trying to copy files to my Android tablet and for two days I am getting this error: libmtp error: could not send object, and after I tried some solutions on and off this website, the error trasformed to libmtp error: Unknown error.

I must say, however, that copying file from my tablet to my Ubuntu works quite fine.

Can any one PLEASE help?

8
  • 2
    Please edit your question and add what you actually have tried. Just telling us that you have tried everything doesn't tell us what you HAVE tried. Please help us help you! Thank you!
    – Terrance
    Sep 9, 2018 at 15:02
  • 3
    I apologize if this seems obvious (it wasn't to me!): Did you turn on your android device and unlock the screen (and make sure it stayed unlocked) before moving the files?
    – Rabbit
    Sep 9, 2018 at 15:12
  • 2
    @Rabbit, I've always turned it on and unlocked itm but never left it unlocked, and VOILA, it worked! I now can never know if one of the solutions I tried worked or it was my fault from the beginning!
    – Mohamed
    Sep 9, 2018 at 17:01
  • 1
    @Rabbit maybe you could add that as an answer since it seemed to be the trick. Or MuAnwar96 you can add the answer yourself (in the answer section below)
    – Zanna
    Sep 10, 2018 at 10:32
  • 1
    Cool beans! I'm so glad I could help (if indeed it was that suggestion that helped in the end). I've added it as an answer.
    – Rabbit
    Sep 10, 2018 at 14:23

2 Answers 2

4

Try turning on your Android device and unlocking the screen (and make sure it stays unlocked / unlock it again) before moving the files.

2
  • 1
    Thanks for making your comment into an answer :) (Note to reviewers of LQP queue: this is apparently what worked for OP - please see the comments on the question.)
    – Zanna
    Sep 10, 2018 at 20:20
  • 1
    This fails to work in my case, the error persists. Any other solution, please?
    – Aminu Kano
    Oct 22, 2019 at 6:36
0

Try with android-file-transfer. Take a look to the latest AppImage (at end-2019).

1
  • No MTP device found
    – Fakhamatia
    Nov 16, 2021 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.