3

[A lot of people have had issues with this but none of the threads have been answered. No one I could find has yet just asked to have the thing removed entirely. I also shouldn't be calling it a "lock screen" If you know what it's called, please edit the title and delete this section]

So I have told the OS not to log me out when the screen goes off due to inactivity and that works well enough, but still this utterly pointless splash screen comes up with the time on it. It takes a long time to go away, maybe 10 seconds (I have a slow computer). Is there any way to get rid of it?

What used to happen in previous iterations is the screen would switch off, then immediately switch back on with movement of the cursor. No splash screen. How do I do that?

Thank you.

(Some little design comments:

  • The splashscreen serves no purpose and should not be enabled by default.
  • Increasing the number of clicks people have to make to get to what they are doing should not be done unless it confers some nameable practical benefit.
  • Asking people to swipe upwards when they don't have a touch screen is silly. It should disappear with a click.
  • Otherwise I absolutely adore 18.04)

5
  • Check in the settings it should be possible to disable it there, check power section Sep 9, 2018 at 15:10
  • Hmmm.. I can't find anything about this in the settings, there is a place to change the lock screen image, but no where I can see to disable it completely.
    – Rabbit
    Sep 9, 2018 at 15:17
  • 1
    Modify the time out I use that on my vm's on mobile now would have checked Sep 9, 2018 at 20:48
  • Well, I would still like the screen to go black to save power, but you are right, just leaving it on all the time is the next best thing. Thanks!
    – Rabbit
    Sep 10, 2018 at 14:29
  • 1
    Does the command from askubuntu.com/questions/1048774/disabling-lock-screen-18-04 work for you? Nov 5, 2018 at 17:06

1 Answer 1

3

There is a Gnome Shell extension that takes care of this issue. The easiest way to install it in Ubuntu is:

  1. Launch Ubuntu Software application.
  2. Search for “Disable Screen Shield”.
  3. Install it.

If you already disabled Automatic Screen Lock in Settings > Privacy, it should work as expected after the screen goes blank due to inactivity: you'll see your desktop straight away.

2
  • Ubuntu 18.04 uses GNOME 3.28, which isn't listed as a version supported by that extension.
    – Miral
    Jul 18, 2019 at 6:41
  • 2
    Worked for me on Ubuntu 18.04.3 LTS
    – pjvleeuwen
    Dec 30, 2019 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.